summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2012-04-07 01:02:48 +0200
committerSebastian Pipping <sebastian@pipping.org>2012-04-07 01:04:36 +0200
commit05ffb8718e0ec69ffa90cc0dca05c599e8160686 (patch)
tree93c7193c759fbbec2bf32e89a7f61fe42f92cd27
parentFix report of 6.0-r9 as a version bump with 6.0-r3 in the Gentoo main tree al... (diff)
downloadoverlint-05ffb8718e0ec69ffa90cc0dca05c599e8160686.tar.gz
overlint-05ffb8718e0ec69ffa90cc0dca05c599e8160686.tar.bz2
overlint-05ffb8718e0ec69ffa90cc0dca05c599e8160686.zip
Use distutilsv0.4.10.4.1
-rw-r--r--.gitignore3
-rw-r--r--Makefile10
-rw-r--r--overlint/cli.py2
-rwxr-xr-xsetup.py18
4 files changed, 31 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
index 2f78cf5..2d64802 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
*.pyc
-
+/dist
+/MANIFEST
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..f28f886
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+# Copyright (C) 2012 Sebastian Pipping <sebastian@pipping.org>
+# Licensed under GPL v2 or later
+
+all:
+
+dist:
+ rm -f MANIFEST
+ ./setup.py sdist
+
+.PHONY: dist
diff --git a/overlint/cli.py b/overlint/cli.py
index d941f25..4ba402c 100644
--- a/overlint/cli.py
+++ b/overlint/cli.py
@@ -3,7 +3,7 @@
from __future__ import print_function
-VERSION_STR = '0.4'
+VERSION_STR = '0.4.1'
import sys
import os
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..08244ba
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,18 @@
+#!/usr/bin/env python
+# Copyright (C) 2012 Sebastian Pipping <sebastian@pipping.org>
+# Licensed under GPL v2 or later
+
+from distutils.core import setup
+from overlint.cli import VERSION_STR
+
+setup(
+ name='overlint',
+ description='Simple tool for static analysis of Gentoo overlays',
+ license='GPL v2 or later',
+ version=VERSION_STR,
+ url='http://git.overlays.gentoo.org/gitweb/?p=proj/overlint.git;a=summary',
+ author='Sebastian Pipping',
+ author_email='sebastian@pipping.org',
+ packages=['overlint', ],
+ scripts=['overlint-cli', ],
+)