aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2013-08-25 12:05:25 +0200
committerTheo Chatzimichos <tampakrap@gentoo.org>2013-08-25 23:34:49 +0200
commit5ee9389470a71a37b8d98fcdc5ffc5a9792572b2 (patch)
treed3908d15374a8010da488d56a6d6901c48e61414 /bin
parentswitch back to non-relative imports, they proved to be confusing (diff)
downloadidentity.gentoo.org-5ee9389470a71a37b8d98fcdc5ffc5a9792572b2.tar.gz
identity.gentoo.org-5ee9389470a71a37b8d98fcdc5ffc5a9792572b2.tar.bz2
identity.gentoo.org-5ee9389470a71a37b8d98fcdc5ffc5a9792572b2.zip
Add flake8 support in runtests
Diffstat (limited to 'bin')
-rwxr-xr-xbin/runtests5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/runtests b/bin/runtests
index 5060cf3..8ac52be 100755
--- a/bin/runtests
+++ b/bin/runtests
@@ -1,10 +1,11 @@
#!/bin/bash
-while getopts sa:dc arg; do
+while getopts sa:dcf arg; do
case ${arg} in
s) SETTINGS="--settings=okupy.tests.settings" ;;
d) TDAEMON="tdaemon -t django" ;;
c) COVERAGE="coverage" ;;
+ f) FLAKE8="flake8 . --exclude=./okupy/tests/settings.py,./okupy/settings,setup.py" ;;
2) SUFFIX="2" ;;
esac
done
@@ -20,3 +21,5 @@ else
echo "Executing: $COMMAND"
$COMMAND
fi
+
+${FLAKE8}