summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-07-23 22:07:25 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-07-23 22:07:25 -0500
commit019ef9c7a76962c3218848c8dbd18ca8052f031e (patch)
tree8a1ddabbc3b565717b7a6dd52bb894e958185b39
parent[ GLSA 202107-53 ] Leptonica: Multiple vulnerabilities (diff)
downloadglsa-019ef9c7a76962c3218848c8dbd18ca8052f031e.tar.gz
glsa-019ef9c7a76962c3218848c8dbd18ca8052f031e.tar.bz2
glsa-019ef9c7a76962c3218848c8dbd18ca8052f031e.zip
[ GLSA 202107-54 ] libyang: Multiple vulnerabilities
Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--glsa-202107-54.xml50
1 files changed, 50 insertions, 0 deletions
diff --git a/glsa-202107-54.xml b/glsa-202107-54.xml
new file mode 100644
index 0000000..83bb578
--- /dev/null
+++ b/glsa-202107-54.xml
@@ -0,0 +1,50 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
+<glsa id="202107-54">
+ <title>libyang: Multiple vulnerabilities</title>
+ <synopsis>Multiple vulnerabilities have been found in libyang, the worst of
+ which could result in a Denial of Service condition.
+ </synopsis>
+ <product type="ebuild">libyang</product>
+ <announced>2021-07-24</announced>
+ <revised count="1">2021-07-24</revised>
+ <bug>791373</bug>
+ <access>remote</access>
+ <affected>
+ <package name="net-libs/libyang" auto="yes" arch="*">
+ <unaffected range="ge">1.0.236</unaffected>
+ <vulnerable range="lt">1.0.236</vulnerable>
+ </package>
+ </affected>
+ <background>
+ <p>YANG data modeling language library.</p>
+ </background>
+ <description>
+ <p>Multiple vulnerabilities have been discovered in libyang. Please review
+ the CVE identifiers referenced below for details.
+ </p>
+ </description>
+ <impact type="low">
+ <p>Please review the referenced CVE identifiers for details.</p>
+ </impact>
+ <workaround>
+ <p>There is no known workaround at this time.</p>
+ </workaround>
+ <resolution>
+ <p>All libyang users should upgrade to the latest version:</p>
+
+ <code>
+ # emerge --sync
+ # emerge --ask --oneshot --verbose "&gt;=net-libs/libyang-1.0.236"
+ </code>
+ </resolution>
+ <references>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28902">CVE-2021-28902</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28903">CVE-2021-28903</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28904">CVE-2021-28904</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28905">CVE-2021-28905</uri>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-28906">CVE-2021-28906</uri>
+ </references>
+ <metadata tag="requester" timestamp="2021-07-24T02:37:39Z">ajak</metadata>
+ <metadata tag="submitter" timestamp="2021-07-24T03:07:13Z">ajak</metadata>
+</glsa>