summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-01-27 05:33:39 +0000
committerSam James <sam@gentoo.org>2022-01-27 05:34:25 +0000
commit3b7263dbbe36631a95b29efe1f17ce9dfb40cc90 (patch)
treebaa0e991a54e1343f312d03b6d3668ee433c99aa
parent[ GLSA 202107-55 ] SDL 2: Multiple vulnerabilities (diff)
downloadglsa-3b7263dbbe36631a95b29efe1f17ce9dfb40cc90.tar.gz
glsa-3b7263dbbe36631a95b29efe1f17ce9dfb40cc90.tar.bz2
glsa-3b7263dbbe36631a95b29efe1f17ce9dfb40cc90.zip
[ GLSA 202201-01 ] Polkit: Local privilege escalation
Bug: https://bugs.gentoo.org/832057 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--glsa-202201-01.xml43
1 files changed, 43 insertions, 0 deletions
diff --git a/glsa-202201-01.xml b/glsa-202201-01.xml
new file mode 100644
index 0000000..cd273ba
--- /dev/null
+++ b/glsa-202201-01.xml
@@ -0,0 +1,43 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
+<glsa id="202201-01">
+ <title>Polkit: Local privilege escalation</title>
+ <synopsis>A vulnerability in polkit could lead to local root privilege escalation.
+ </synopsis>
+ <product type="ebuild">polkit</product>
+ <announced>2022-01-27</announced>
+ <revised count="1">2022-01-27</revised>
+ <bug>832057</bug>
+ <access>local</access>
+ <affected>
+ <package name="sys-auth/polkit" auto="yes" arch="*">
+ <unaffected range="ge">0.120-r2</unaffected>
+ <vulnerable range="lt">0.120-r2</vulnerable>
+ </package>
+ </affected>
+ <background>
+ <p>polkit is a toolkit for managing policies related to unprivileged processes communicating with privileged process. </p>
+ </background>
+ <description>
+ <p>Flawed input validation of arguments was discovered in the &#39;pkexec&#39; program&#39;s main() function.</p>
+ </description>
+ <impact type="high">
+ <p>A local attacker could achieve root privilege escalation.</p>
+ </impact>
+ <workaround>
+ <p>Run the following command as root:
+# chmod 0755 /usr/bin/pkexec</p>
+ </workaround>
+ <resolution>
+ <p>Upgrade Polkit to a patched version.</p>
+
+ <code>
+ emerge --ask --verbose &#34;&gt;=sys-auth/polkit-0.120-r2&#34;
+ </code>
+ </resolution>
+ <references>
+ <uri link="https://nvd.nist.gov/vuln/detail/CVE-2021-4034">CVE-2021-4034</uri>
+ </references>
+ <metadata tag="requester" timestamp="2022-01-27T04:56:33.847737Z">sam</metadata>
+ <metadata tag="submitter" timestamp="2022-01-27T04:56:33.851433Z">sam</metadata>
+</glsa>