summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vlc')
-rw-r--r--media-video/vlc/Manifest15
-rw-r--r--media-video/vlc/files/vlc-2.1.0-freetype-proper-default-font.patch17
-rw-r--r--media-video/vlc/files/vlc-2.1.0-newer-rdp.patch47
-rw-r--r--media-video/vlc/metadata.xml73
-rw-r--r--media-video/vlc/vlc-2.1.0.ebuild350
5 files changed, 502 insertions, 0 deletions
diff --git a/media-video/vlc/Manifest b/media-video/vlc/Manifest
new file mode 100644
index 0000000..78303e5
--- /dev/null
+++ b/media-video/vlc/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST vlc-2.1.0.tar.xz 19571224 SHA256 d2177daa31786acf1e961b2f63429797a8c62c090e5359bcc7929a1ba5fe41f7 SHA512 abf397e1382289d579fec3dc540885c45ba055f158f7c248c5de27a7c50dac5a4c317145c4a786ed3819a9199fc304fa8f43ccde8c33c2938d40c805e7e9b124 WHIRLPOOL 4357db6bf832e3d549bca9bde547c52f6ce4cf5f43874a6931863e2cce8b0bfeac7ba4aa2fab94c2a82ae106f15dd60156cafdc51bf158746ff2bf2a2eee5666
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.21 (GNU/Linux)
+
+iQEcBAEBCAAGBQJSRBKiAAoJEJWyH81tNOV9IBUIAJTPin81UUdQY1XgeZVlZTpl
+A93yHp+GjIfC9NlDgw7XtX3xGODVdFXz6GPLsFh+ZKsO5fk7z0UXEdkMwIobrZ1a
+6utzJeurCAluibi/9AOc+u3jhqtr1939n+EQ+TevOR8xGkBp25lTiU3Z+pW6AfGv
+mt7/kT2d35O6cwbLAXu1hdajK77KjEAlr9DCsZq6MTP47qSbbb2p7VioKD3WuxVk
+wPeUDLAb9izXVxEkh+BGsJ1n3Oo1RWz2xWvVAktQisFFVM5/LFxQHuuDGqY6kQjZ
+v0vpC66J63sC/cFdhgWB3PudjTuXlh8rgTpzR5syg5PjVI2F6XbR4RjQaeFnXLs=
+=PYKv
+-----END PGP SIGNATURE-----
diff --git a/media-video/vlc/files/vlc-2.1.0-freetype-proper-default-font.patch b/media-video/vlc/files/vlc-2.1.0-freetype-proper-default-font.patch
new file mode 100644
index 0000000..37e95fe
--- /dev/null
+++ b/media-video/vlc/files/vlc-2.1.0-freetype-proper-default-font.patch
@@ -0,0 +1,17 @@
+--- a/modules/text_renderer/freetype.c
++++ b/modules/text_renderer/freetype.c
+@@ -67,10 +67,10 @@
+ # define SYSTEM_DEFAULT_MONOSPACE_FONT_FILE "/system/fonts/DroidSansMono.ttf"
+ # define SYSTEM_DEFAULT_MONOSPACE_FAMILY "Droid Sans Mono"
+ #else
+-# define SYSTEM_DEFAULT_FONT_FILE "/usr/share/fonts/truetype/freefont/FreeSerifBold.ttf"
+-# define SYSTEM_DEFAULT_FAMILY "Serif Bold"
+-# define SYSTEM_DEFAULT_MONOSPACE_FONT_FILE "/usr/share/fonts/truetype/freefont/FreeMono.ttf"
+-# define SYSTEM_DEFAULT_MONOSPACE_FAMILY "Monospace"
++# define SYSTEM_DEFAULT_FONT_FILE "/usr/share/fonts/dejavu/DejaVuSans.ttf"
++# define SYSTEM_DEFAULT_FAMILY "DejaVu Sans"
++# define SYSTEM_DEFAULT_MONOSPACE_FONT_FILE "/usr/share/fonts/dejavu/DejaVuSansMono.ttf"
++# define SYSTEM_DEFAULT_MONOSPACE_FAMILY "DejaVu Sans Mono"
+ #endif
+
+ #ifndef DEFAULT_FONT_FILE
diff --git a/media-video/vlc/files/vlc-2.1.0-newer-rdp.patch b/media-video/vlc/files/vlc-2.1.0-newer-rdp.patch
new file mode 100644
index 0000000..aa1957a
--- /dev/null
+++ b/media-video/vlc/files/vlc-2.1.0-newer-rdp.patch
@@ -0,0 +1,47 @@
+--- a/modules/access/rdp.c
++++ b/modules/access/rdp.c
+@@ -198,15 +198,15 @@
+ demux_sys_t *p_sys = p_vlccontext->p_demux->p_sys;
+
+ /* Configure connexion */
+- p_instance->settings->sw_gdi = true; /* render in buffer */
+- p_instance->settings->fullscreen = true;
+- p_instance->settings->hostname = strdup( p_sys->psz_hostname );
+- p_instance->settings->username =
++ p_instance->settings->SoftwareGdi = true; /* render in buffer */
++ p_instance->settings->Fullscreen = true;
++ p_instance->settings->ServerHostname = strdup( p_sys->psz_hostname );
++ p_instance->settings->Username =
+ var_InheritString( p_vlccontext->p_demux, CFG_PREFIX "user" );
+- p_instance->settings->password =
++ p_instance->settings->Password =
+ var_InheritString( p_vlccontext->p_demux, CFG_PREFIX "password" );
+- p_instance->settings->port = p_sys->i_port;
+- p_instance->settings->encryption =
++ p_instance->settings->ServerPort = p_sys->i_port;
++ p_instance->settings->EncryptionMethods =
+ var_InheritBool( p_vlccontext->p_demux, CFG_PREFIX "encrypt" );
+
+ return true;
+@@ -217,9 +217,9 @@
+ vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_instance->context;
+
+ msg_Dbg( p_vlccontext->p_demux, "connected to desktop %dx%d (%d bpp)",
+- p_instance->settings->width,
+- p_instance->settings->height,
+- p_instance->settings->color_depth );
++ p_instance->settings->DesktopWidth,
++ p_instance->settings->DesktopHeight,
++ p_instance->settings->ColorDepth );
+
+ p_instance->update->DesktopResize = desktopResizeHandler;
+ p_instance->update->BeginPaint = beginPaintHandler;
+@@ -415,7 +415,7 @@
+ p_sys->p_instance->Authenticate = authenticateHandler;
+
+ /* Set up context handlers and let it be allocated */
+- p_sys->p_instance->context_size = sizeof( vlcrdp_context_t );
++ p_sys->p_instance->ContextSize = sizeof( vlcrdp_context_t );
+ freerdp_context_new( p_sys->p_instance );
+
+ vlcrdp_context_t * p_vlccontext = (vlcrdp_context_t *) p_sys->p_instance->context;
diff --git a/media-video/vlc/metadata.xml b/media-video/vlc/metadata.xml
new file mode 100644
index 0000000..2541251
--- /dev/null
+++ b/media-video/vlc/metadata.xml
@@ -0,0 +1,73 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>TomWij@gentoo.org</email>
+ <name>Tom Wijsman</name>
+ </maintainer>
+ <use>
+ <flag name="atmo">Enables support for AtmoLight (homebrew Ambient Lighting Technology)</flag>
+ <flag name="audioqueue">Enables AudioQueue audio module for Mac OS X.</flag>
+ <flag name="avcodec">Enables libavcodec support for video/audio encoding/decoding. libavcodec is part of FFmpeg.</flag>
+ <flag name="avformat">Enables libformat support for reading and writing various media containers. libavformat is part of FFmpeg.</flag>
+ <flag name="bluray">Enables libbluray for Blu-ray disc support.</flag>
+ <flag name="dc1394">Enables IIDC cameras support.</flag>
+ <flag name="dirac">Enable Dirac video support (an advanced royalty-free video compression format) via the reference library: dirac.</flag>
+ <flag name="direct2d">Enable Win7/VistaPU Direct2D support.</flag>
+ <flag name="directx">Enable Win32 DirectX support.</flag>
+ <flag name="dshow">Enables Win32 DirectShow support.</flag>
+ <flag name="dvbpsi">Enables support for Mpeg-TS files (.ts, .m2ts, .mts) via <pkg>media-libs/libdvbpsi</pkg>.</flag>
+ <flag name="dxva2">Enables Win32 DxVA2 support.</flag>
+ <flag name="egl">Enables EGL video output module.</flag>
+ <flag name="fbosd">Enables the framebuffer overlay plugin.</flag>
+ <flag name="fluidsynth">Enables Fluidsynth MIDI software synthesis (with external sound fonts).</flag>
+ <flag name="gcrypt">Enables cryptography support via libgcrypt.</flag>
+ <flag name="gme">Enables support for <pkg>media-libs/game-music-emu</pkg> for playing various video game music formats.</flag>
+ <flag name="gnome">Adds support for GNOME's filesystem abstraction layer, <pkg>gnome-base/gnome-vfs</pkg>. This flag is not GUI-related.</flag>
+ <flag name="growl">Enables growl notification support (over UDP for remote access and native on OSX)</flag>
+ <flag name="httpd">Enables a web based interface for vlc.</flag>
+ <flag name="ios-vout">Enables iPhone OS video output.</flag>
+ <flag name="kate">Adds support for Ogg Kate subtitles via libkate.</flag>
+ <flag name="libproxy">Enables support for proxy settings in the HTTP access module.</flag>
+ <flag name="libtar">Uses libtar instead of the built-in tar reader for reading custom skins.</flag>
+ <flag name="libtiger">Enables Ogg Kate subtitles rendering using libtiger.</flag>
+ <flag name="linsys">Enables support for Linux Linear Systems Ltd. SDI and HD-SDI input cards.</flag>
+ <flag name="live">Enables live555 streaming media support (client support for rtsp).</flag>
+ <flag name="macosx">Enables Mac OS X gui support.</flag>
+ <flag name="macosx-audio">Enables Mac OS X audio module.</flag>
+ <flag name="macosx-dialog-provider">Enables Mac OS X dialog module.</flag>
+ <flag name="macosx-eyetv">Enables Mac OS X EyeTV (TNT Tuner) module.</flag>
+ <flag name="macosx-quartztext">Enables Mac OS X quartz text module.</flag>
+ <flag name="macosx-qtkit">Enables Mac OS X qtkit module: qtcapture (video) and qtsound (audio) module.</flag>
+ <flag name="macosx-vout">Enables Mac OS X video output module.</flag>
+ <flag name="matroska">Enables matroska support using reference libraries (fallback on other existing matroska support if disabled, i.e., matroska enabled FFmpeg)</flag>
+ <flag name="media-library">Build the (sqlite based) media library.</flag>
+ <flag name="omxil">Enables OpenMAX Integration Layer codec module.</flag>
+ <flag name="optimisememory">Enable optimisation for memory rather than performance.</flag>
+ <flag name="opus">Support opus decoding via libopus.</flag>
+ <flag name="postproc">Enables image post-processing via libpostproc (part of FFmpeg).</flag>
+ <flag name="projectm">Enables the projectM visualization plugin.</flag>
+ <flag name="pvr">Enables PVR cards access module.</flag>
+ <flag name="qt4" restrict="&gt;=media-video/vlc-0.9">Builds a <pkg>x11-libs/qt</pkg> based frontend. It is now the most up-to-date graphical interface available.</flag>
+ <flag name="rtsp">Enables real audio and RTSP modules.</flag>
+ <flag name="run-as-root">Allows vlc to start for root. Don't enable this unless you have a very specific (e.g. embedded) need for it!</flag>
+ <flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
+ <flag name="sid">Adds support for playing C64 SID files through <pkg>media-libs/libsidplay-2</pkg>.</flag>
+ <flag name="sdl-image">Enables sdl image video decoder (depends on sdl)</flag>
+ <flag name="shine">Enables shine fixed point mp3 encoder.</flag>
+ <flag name="shout">Enables libshout output.</flag>
+ <flag name="skins">Enables support for the skins2 interface.</flag>
+ <flag name="switcher">Enables MPEG2 video switcher stream output module.</flag>
+ <flag name="swscale">Enables image scaling and conversion via libswscale (part of FFmpeg).</flag>
+ <flag name="twolame">Enables twolame support (MPEG Audio Layer 2 encoder).</flag>
+ <flag name="upnp">Enables support for Intel UPnP stack.</flag>
+ <flag name="vaapi">Enables VAAPI (Video Acceleration API) for hardware decoding</flag>
+ <flag name="vcdx">Enables VCD with navigation via libvcdinfo (depends on cdio)</flag>
+ <flag name="vlm">New videolan (media) manager (vlm), a little manager designed to launch and manage multiple streams from within one instance of VLC.</flag>
+ <flag name="waveout">Enable win32 waveOut plugin.</flag>
+ <flag name="wingdi">Enable Win32 GDI module.</flag>
+ <flag name="wma-fixed">Enables fixed point WMA decoder.</flag>
+ <flag name="X">Enables support for, e.g., fullscreen mode via the X Window System. By itself, this flag does not build a graphical interface.</flag>
+ <flag name="zvbi">Enables support for teletext subtitles via the zvbi library.</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/vlc/vlc-2.1.0.ebuild b/media-video/vlc/vlc-2.1.0.ebuild
new file mode 100644
index 0000000..0f8033c
--- /dev/null
+++ b/media-video/vlc/vlc-2.1.0.ebuild
@@ -0,0 +1,350 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/vlc/vlc-2.0.7.ebuild,v 1.8 2013/09/05 10:45:56 ago Exp $
+
+EAPI="5"
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=git-2
+ EGIT_BOOTSTRAP="bootstrap"
+ if [ "${PV%.9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.videolan.org/vlc/vlc-${PV%.9999}.git"
+ else
+ EGIT_REPO_URI="git://git.videolan.org/vlc.git"
+ fi
+fi
+
+inherit eutils multilib autotools toolchain-funcs flag-o-matic ${SCM}
+
+MY_PV="${PV/_/-}"
+MY_PV="${MY_PV/-beta/-test}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="VLC media player - Video player and streamer"
+HOMEPAGE="http://www.videolan.org/vlc/"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+ SRC_URI=""
+elif [[ "${MY_P}" == "${P}" ]]; then
+ SRC_URI="http://download.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.xz"
+else
+ SRC_URI="http://download.videolan.org/pub/videolan/testing/${MY_P}/${MY_P}.tar.xz"
+fi
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+
+if [ "${PV%9999}" = "${PV}" ] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 -sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+else
+ KEYWORDS=""
+fi
+IUSE="a52 aac aalib alsa altivec atmo +audioqueue avahi +avcodec
+ +avformat bidi bluray cdda cddb dbus dc1394 debug dirac direct2d
+ directfb directx dshow dts dvb +dvbpsi dvd dxva2 elibc_glibc egl +encode
+ fbosd fluidsynth +ffmpeg flac fontconfig +gcrypt gme gnome gnutls
+ growl httpd ieee1394 ios-vout jack kate kde libass libcaca libnotify
+ libproxy libsamplerate libtiger linsys libtar lirc live lua +macosx
+ +macosx-audio +macosx-dialog-provider +macosx-eyetv +macosx-quartztext
+ +macosx-qtkit +macosx-vout matroska media-library mmx modplug mp3 mpeg
+ mtp musepack ncurses neon ogg omxil opengl opus optimisememory oss png
+ portaudio +postproc projectm pulseaudio pvr +qt4 rtsp run-as-root samba
+ schroedinger sdl sdl-image shine shout sid skins speex sqlite sse svg
+ +swscale switcher taglib theora truetype twolame udev upnp vaapi v4l
+ vcdx vlm vorbis waveout wingdi wma-fixed +X x264 +xcb xml
+ xosd xv zvbi"
+
+RDEPEND="
+ >=sys-libs/zlib-1.2.5.1-r2[minizip]
+ a52? ( >=media-libs/a52dec-0.7.4-r3 )
+ aalib? ( media-libs/aalib )
+ aac? ( >=media-libs/faad2-2.6.1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.23 )
+ avahi? ( >=net-dns/avahi-0.6[dbus] )
+ avcodec? ( virtual/ffmpeg )
+ avformat? ( virtual/ffmpeg )
+ bidi? ( >=dev-libs/fribidi-0.10.4 )
+ bluray? ( >=media-libs/libbluray-0.2.1 )
+ cddb? ( >=media-libs/libcddb-1.2.0 )
+ dbus? ( >=sys-apps/dbus-1.0.2 )
+ dc1394? ( >=sys-libs/libraw1394-2.0.1 >=media-libs/libdc1394-2.0.2 )
+ dirac? ( >=media-video/dirac-0.10.0 )
+ directfb? ( dev-libs/DirectFB sys-libs/zlib )
+ dts? ( media-libs/libdca )
+ dvbpsi? ( >=media-libs/libdvbpsi-0.2.1 )
+ dvd? ( media-libs/libdvdread >=media-libs/libdvdnav-0.1.9 )
+ egl? ( virtual/opengl )
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ flac? ( media-libs/libogg >=media-libs/flac-1.1.2 )
+ fluidsynth? ( media-sound/fluidsynth )
+ fontconfig? ( media-libs/fontconfig )
+ gcrypt? ( >=dev-libs/libgcrypt-1.2.0 )
+ gme? ( media-libs/game-music-emu )
+ gnome? ( gnome-base/gnome-vfs )
+ gnutls? ( >=net-libs/gnutls-2.0.0 )
+ ieee1394? ( >=sys-libs/libraw1394-2.0.1 >=sys-libs/libavc1394-0.5.3 )
+ ios-vout? ( virtual/opengl )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.99.0-r1 )
+ kate? ( >=media-libs/libkate-0.1.1 )
+ libass? ( >=media-libs/libass-0.9.8 media-libs/fontconfig )
+ libcaca? ( >=media-libs/libcaca-0.99_beta14 )
+ libnotify? ( x11-libs/libnotify x11-libs/gtk+:2 )
+ libproxy? ( net-libs/libproxy )
+ libsamplerate? ( media-libs/libsamplerate )
+ libtar? ( >=dev-libs/libtar-1.2.11-r3 )
+ libtiger? ( media-libs/libtiger )
+ linsys? ( >=media-libs/zvbi-0.2.28 )
+ lirc? ( app-misc/lirc )
+ live? ( >=media-plugins/live-2011.12.23 )
+ lua? ( >=dev-lang/lua-5.1 )
+ macosx-vout? ( virtual/opengl )
+ matroska? ( >=dev-libs/libebml-1.0.0 >=media-libs/libmatroska-1.0.0 )
+ modplug? ( >=media-libs/libmodplug-0.8.8.1 )
+ mp3? ( media-libs/libmad )
+ mpeg? ( >=media-libs/libmpeg2-0.3.2 )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ musepack? ( >=media-sound/musepack-tools-444 )
+ ncurses? ( >=sys-libs/ncurses-5.9-r2[unicode] )
+ ogg? ( media-libs/libogg )
+ opengl? ( virtual/opengl >=x11-libs/libX11-1.3.99.901 )
+ opus? ( media-libs/opus )
+ png? ( media-libs/libpng sys-libs/zlib )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ postproc? ( || ( media-video/ffmpeg:0 media-libs/libpostproc ) )
+ projectm? ( media-libs/libprojectm )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.22 )
+ qt4? ( dev-qt/qtgui:4 dev-qt/qtcore:4 )
+ samba? ( >=net-fs/samba-3.4.6[smbclient] )
+ schroedinger? ( >=media-libs/schroedinger-1.0.10 )
+ sdl? ( >=media-libs/libsdl-1.2.8
+ sdl-image? ( media-libs/sdl-image sys-libs/zlib ) )
+ shout? ( media-libs/libshout )
+ sid? ( media-libs/libsidplay:2 )
+ skins? ( x11-libs/libXext x11-libs/libXpm x11-libs/libXinerama )
+ speex? ( media-libs/speex )
+ sqlite? ( >=dev-db/sqlite-3.6.0:3 )
+ svg? ( >=gnome-base/librsvg-2.9.0 )
+ swscale? ( virtual/ffmpeg )
+ taglib? ( >=media-libs/taglib-1.5 sys-libs/zlib )
+ theora? ( >=media-libs/libtheora-1.0_beta3 )
+ truetype? ( media-libs/freetype virtual/ttf-fonts
+ !fontconfig? ( media-fonts/dejavu ) )
+ twolame? ( media-sound/twolame )
+ udev? ( virtual/udev )
+ upnp? ( net-libs/libupnp )
+ v4l? ( media-libs/libv4l )
+ vaapi? ( x11-libs/libva )
+ vcdx? ( >=dev-libs/libcdio-0.78.2 >=media-video/vcdimager-0.7.22 )
+ vorbis? ( media-libs/libvorbis )
+ X? ( x11-libs/libX11 )
+ x264? ( >=media-libs/x264-0.0.20090923:= )
+ xcb? ( >=x11-libs/libxcb-1.6 >=x11-libs/xcb-util-0.3.4 )
+ xml? ( dev-libs/libxml2 )
+ xosd? ( x11-libs/xosd )
+ zvbi? ( >=media-libs/zvbi-0.2.25 )
+ "
+
+DEPEND="${RDEPEND}
+ fbosd? ( sys-kernel/linux-headers )
+ kde? ( >=kde-base/kdelibs-4 )
+ xcb? ( x11-proto/xproto )
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+REQUIRED_USE="
+ aalib? ( X )
+ bidi? ( truetype )
+ cddb? ( cdda )
+ dvb? ( dvbpsi )
+ dxva2? ( avcodec )
+ egl? ( X )
+ ffmpeg? ( avcodec avformat swscale postproc )
+ fontconfig? ( truetype )
+ gnutls? ( gcrypt )
+ httpd? ( lua )
+ libcaca? ( X )
+ libtar? ( skins )
+ libtiger? ( kate )
+ media-library? ( sqlite )
+ qt4? ( X )
+ sdl? ( X )
+ skins? ( truetype qt4 X )
+ switcher? ( avcodec )
+ vaapi? ( avcodec X )
+ vlm? ( encode )
+ xosd? ( X )
+ xv? ( xcb )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ if [ "${PV%9999}" != "${PV}" ] ; then
+ git-2_src_unpack
+ fi
+}
+
+src_prepare() {
+ # Make it build with libtool 1.5
+ rm -f m4/lt* m4/libtool.m4
+
+ epatch "${FILESDIR}"/${P}-freetype-proper-default-font.patch
+ epatch "${FILESDIR}"/${P}-newer-rdp.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ # needs libresid-builder from libsidplay:2 which is in another directory...
+ # FIXME!
+ use sid && append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
+
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable a52) \
+ $(use_enable aalib aa) \
+ $(use_enable aac faad) \
+ $(use_enable alsa) \
+ $(use_enable altivec) \
+ $(use_enable atmo) \
+ $(use_enable audioqueue) \
+ $(use_enable avahi bonjour) \
+ $(use_enable avcodec) \
+ $(use_enable avformat) \
+ $(use_enable bidi fribidi) \
+ $(use_enable bluray) \
+ $(use_enable cdda vcd) \
+ $(use_enable cddb libcddb) \
+ $(use_enable dbus) $(use_enable dbus dbus-control) \
+ $(use_enable dirac) \
+ $(use_enable direct2d) \
+ $(use_enable directfb) \
+ $(use_enable directx) \
+ $(use_enable dc1394) \
+ $(use_enable debug) \
+ $(use_enable dshow) \
+ $(use_enable dts dca) \
+ $(use_enable dvbpsi) \
+ $(use_enable dvd dvdread) $(use_enable dvd dvdnav) \
+ $(use_enable dxva2) \
+ $(use_enable egl) \
+ $(use_enable encode sout) \
+ $(use_enable fbosd) \
+ $(use_enable flac) \
+ $(use_enable fluidsynth) \
+ $(use_enable fontconfig) \
+ $(use_enable gcrypt libgcrypt) \
+ $(use_enable gme) \
+ $(use_enable gnome gnomevfs) \
+ $(use_enable gnutls) \
+ $(use_enable growl) \
+ $(use_enable httpd) \
+ $(use_enable ieee1394 dv) \
+ $(use_enable ios-vout) \
+ $(use_enable jack) \
+ $(use_enable kate) \
+ $(use_with kde kde-solid) \
+ $(use_enable libass) \
+ $(use_enable libcaca caca) \
+ $(use_enable libnotify notify) \
+ $(use_enable libproxy) \
+ $(use_enable libsamplerate samplerate) \
+ $(use_enable libtar) \
+ $(use_enable libtiger tiger) \
+ $(use_enable linsys) \
+ $(use_enable lirc) \
+ $(use_enable live live555) \
+ $(use_enable lua) \
+ $(use_enable macosx-audio) \
+ $(use_enable macosx-dialog-provider) \
+ $(use_enable macosx-eyetv) \
+ $(use_enable macosx-qtkit) \
+ $(use_enable macosx-quartztext) \
+ $(use_enable macosx-vout) \
+ $(use_enable matroska mkv) \
+ $(use_enable media-library) \
+ $(use_enable mmx) \
+ $(use_enable modplug mod) \
+ $(use_enable mp3 mad) \
+ $(use_enable mpeg libmpeg2) \
+ $(use_enable mtp) \
+ $(use_enable musepack mpc) \
+ $(use_enable ncurses) \
+ $(use_enable neon) \
+ $(use_enable ogg) $(use_enable ogg mux_ogg) \
+ $(use_enable omxil) \
+ $(use_enable opengl glx) \
+ $(use_enable opus) \
+ $(use_enable optimisememory optimize-memory) \
+ $(use_enable oss) \
+ $(use_enable png) \
+ $(use_enable portaudio) \
+ $(use_enable postproc) \
+ $(use_enable projectm) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable pvr) \
+ $(use_enable qt4) \
+ $(use_enable rtsp realrtsp) \
+ $(use_enable run-as-root) \
+ $(use_enable samba smb) \
+ $(use_enable schroedinger) \
+ $(use_enable sdl) \
+ $(use_enable sdl-image) \
+ $(use_enable shine) \
+ $(use_enable sid) \
+ $(use_enable shout) \
+ $(use_enable skins skins2) \
+ $(use_enable speex) \
+ $(use_enable sqlite) \
+ $(use_enable sse) \
+ $(use_enable svg) \
+ $(use_enable switcher) \
+ $(use_enable swscale) \
+ $(use_enable taglib) \
+ $(use_enable theora) \
+ $(use_enable truetype freetype) \
+ $(use_enable twolame) \
+ $(use_enable udev) \
+ $(use_enable upnp) \
+ $(use_enable v4l v4l2) \
+ $(use_enable vaapi libva) \
+ $(use_enable vcdx) \
+ $(use_enable vlm) \
+ $(use_enable vorbis) \
+ $(use_enable waveout) \
+ $(use_enable wingdi) \
+ $(use_enable wma-fixed) \
+ $(use_with X x) \
+ $(use_enable x264) \
+ $(use_enable xcb) \
+ $(use_enable xml libxml2) \
+ $(use_enable xosd) \
+ $(use_enable xv xvideo) \
+ $(use_enable zvbi) $(use_enable !zvbi telx) \
+ --disable-loader \
+ --disable-optimizations \
+ --without-tuning \
+ --enable-fast-install
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS THANKS NEWS README \
+ doc/fortunes.txt doc/intf-vcd.txt
+
+ # Punt useless libtool's .la files
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x "/usr/$(get_libdir)/vlc/vlc-cache-gen" ] ; then
+ einfo "Running /usr/$(get_libdir)/vlc/vlc-cache-gen on /usr/$(get_libdir)/vlc/plugins/"
+ "/usr/$(get_libdir)/vlc/vlc-cache-gen" -f "/usr/$(get_libdir)/vlc/plugins/"
+ else
+ ewarn "We cannot run vlc-cache-gen (most likely ROOT!=/)"
+ ewarn "Please run /usr/$(get_libdir)/vlc/vlc-cache-gen manually"
+ ewarn "If you do not do it, vlc will take a long time to load."
+ fi
+}