summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/pybind11/Manifest1
-rw-r--r--dev-libs/pybind11/metadata.xml8
-rw-r--r--dev-libs/pybind11/pybind11-2.2.1.ebuild48
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/pybind11/Manifest b/dev-libs/pybind11/Manifest
new file mode 100644
index 0000000..18d1442
--- /dev/null
+++ b/dev-libs/pybind11/Manifest
@@ -0,0 +1 @@
+DIST pybind11-2.2.1.tar.gz 540643 SHA256 f8bd1509578b2a1e7407d52e6ee8afe64268909a1bbda620ca407318598927e7 SHA512 1bc0646862fabef1111c05403a7238965ce5661a6f53945a1b7c4faad33f039d2ea278de64190099a8ae4fd66487a070de59334a7f32e187060bbbc7e0c3060e WHIRLPOOL 5444206565a14fe102131bf86a35f7e4de8f7ca79c093db3db6cc856c922ef5643bfda4b6dbf37708ce65aa473fcf429883b660fcb7cefb8218141b19d9950c8
diff --git a/dev-libs/pybind11/metadata.xml b/dev-libs/pybind11/metadata.xml
new file mode 100644
index 0000000..3a85ecd
--- /dev/null
+++ b/dev-libs/pybind11/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="man">Build and install documentation as manpages</flag>
+ <flag name="info">Build and install documentation as texinfo</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-libs/pybind11/pybind11-2.2.1.ebuild b/dev-libs/pybind11/pybind11-2.2.1.ebuild
new file mode 100644
index 0000000..7669590
--- /dev/null
+++ b/dev-libs/pybind11/pybind11-2.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight library that exposes C++ types in Python and vice versa"
+HOMEPAGE="https://github.com/wjakob/pybind11"
+SRC_URI="https://github.com/pybind/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc man info"
+
+RDEPEND="info? ( sys-apps/texinfo )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/breathe[${PYTHON_USEDEP}]
+ )
+ man? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/breathe[${PYTHON_USEDEP}]
+ )
+ info? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/breathe[${PYTHON_USEDEP}]
+ )"
+
+python_compile_all() {
+ if use doc || use man || use info; then
+ cd docs || die
+ emake $(use doc && echo html) $(use man && echo man) $(use info && echo info)
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dodoc README.md
+ use doc && dodoc -r docs/.build/html
+ use man && doman docs/.build/man/pybind11.1
+ use info && doinfo docs/.build/texinfo/pybind11.info
+}