summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory A. Pratt <anarchy@gentoo.org>2010-11-30 08:21:35 -0600
committerJory A. Pratt <anarchy@gentoo.org>2010-11-30 08:21:35 -0600
commit1fd30cfc47fe8cb362408bd2fbdf460ca45b22b2 (patch)
tree4ddfda97b2101ef4e44843d4ff593211621a1e77
parentupdate vlc nsplugin installation (diff)
downloadanarchy-1fd30cfc47fe8cb362408bd2fbdf460ca45b22b2.tar.gz
anarchy-1fd30cfc47fe8cb362408bd2fbdf460ca45b22b2.tar.bz2
anarchy-1fd30cfc47fe8cb362408bd2fbdf460ca45b22b2.zip
add libffi live ebuild for those who need to stay current
-rw-r--r--dev-libs/libffi/Manifest1
-rw-r--r--dev-libs/libffi/libffi-9999.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/libffi/Manifest b/dev-libs/libffi/Manifest
new file mode 100644
index 0000000..412af6f
--- /dev/null
+++ b/dev-libs/libffi/Manifest
@@ -0,0 +1 @@
+EBUILD libffi-9999.ebuild 1330 RMD160 39d17ec21805967e1a281183c64d5317fc2b52db SHA1 1d71d7e9451b5417b13f926c647f90a7fe4182bc SHA256 41f58767a646acb890cdb150aef421793b73553b31289f945d6cff272d939827
diff --git a/dev-libs/libffi/libffi-9999.ebuild b/dev-libs/libffi/libffi-9999.ebuild
new file mode 100644
index 0000000..cad6a3d
--- /dev/null
+++ b/dev-libs/libffi/libffi-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils libtool
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/atgreen/libffi.git"
+ inherit git
+ KEYWORDS=""
+else
+ SRC_URI="ftp://sourceware.org/pub/${PN}/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux
+ ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions."
+HOMEPAGE="http://sourceware.org/libffi/"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="debug static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-util/dejagnu )"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ else
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-interix.patch \
+ "${FILESDIR}"/${P}-irix.patch \
+ "${FILESDIR}"/${P}-arm-oabi.patch
+
+ elibtoolize
+ fi
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog* README
+ find "${D}" -type f -name '*.la' -exec rm -f '{}' +
+}