summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-04-16 07:38:05 -0500
committerJory Pratt <anarchy@gentoo.org>2020-04-16 07:38:05 -0500
commite25d508c95b864e78c5052e24e59a848f104b900 (patch)
tree7e6d919c3562a5f66a84d39d2d5b207520123cfb
parentwww-client/firefox: Bump nodejs dep (diff)
downloadanarchy-e25d508c95b864e78c5052e24e59a848f104b900.tar.gz
anarchy-e25d508c95b864e78c5052e24e59a848f104b900.tar.bz2
anarchy-e25d508c95b864e78c5052e24e59a848f104b900.zip
www-client/firefox: Add initial support for PGO on musl
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--www-client/firefox/firefox-76.0_beta4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/www-client/firefox/firefox-76.0_beta4.ebuild b/www-client/firefox/firefox-76.0_beta4.ebuild
index 048d5aa..3a92e8e 100644
--- a/www-client/firefox/firefox-76.0_beta4.ebuild
+++ b/www-client/firefox/firefox-76.0_beta4.ebuild
@@ -318,6 +318,13 @@ src_prepare() {
# Allow user to apply any additional patches without modifing ebuild
eapply_user
+ # prebuilt glibc binary files cause python2.7 segfault on musl
+ if use elibc_musl; then
+ rm "${S}"/third_party/python/psutil/psutil/*.so
+ rm "${S}"/third_party/python/psutil/build/lib.linux-x86_64-2.7/psutil/*.so
+ rm "${S}"/third_party/python/psutil/build/temp.linux-x86_64-2.7/psutil/*.o
+ fi
+
# Enable gnomebreakpad
if use debug ; then
sed -i -e "s:GNOME_DISABLE_CRASH_DIALOG=1:GNOME_DISABLE_CRASH_DIALOG=0:g" \