summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/iucode_tool/Manifest4
-rw-r--r--sys-apps/iucode_tool/files/0001-support-musl-uclibc-argp-standalone.patch39
-rw-r--r--sys-apps/iucode_tool/iucode_tool-2.1.2.ebuild24
-rw-r--r--sys-apps/iucode_tool/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/iucode_tool/Manifest b/sys-apps/iucode_tool/Manifest
new file mode 100644
index 0000000..2b178a1
--- /dev/null
+++ b/sys-apps/iucode_tool/Manifest
@@ -0,0 +1,4 @@
+AUX 0001-support-musl-uclibc-argp-standalone.patch 916 SHA256 7745661eb66a15730028bda984c0033edbbde2189eacdc9cfcb722ebd7c6d1ce SHA512 b331f528c252bd623e8af53aaf9bba8e00631e876fa40ec68741583fd8fc73aabfe6598325c9cec38630429ae0a63d070aafffd3450727f384a1f055c3a451f3 WHIRLPOOL 0991e57005882e3099499c733facba59de4deff0a834b6b68f6a67c93466609632b77af1b7aeaa2587fc6c420de0033ce1515ba82e5dbf58a3a7422ebe834995
+DIST iucode-tool_2.1.2.tar.xz 143352 SHA256 01f1c02ba6935e0ac8440fb594c2ef57ce4437fcbce539e3ef329f55a6fd71ab SHA512 f1af71843160500fb9c0b56bffdb1d3db09acf42f6c0a84a5d5311eedfe809f9ac27f89bf1778cab8261d3a540cfe62f3698a45c76be76e7f40179b9c49050e0 WHIRLPOOL 3ca861e36565c9126041c3cdaf05cc27f18d64580482a2d6b3d889c44b8f08bd1a3f8ae1cd1e27dd708c0a38a75e2fb2ed292e42458065cfc029ae8dba575580
+EBUILD iucode_tool-2.1.2.ebuild 580 SHA256 069b309efed4bfac7cb3afe253bd9b49173bc071fd5632c61296e5ab3db84003 SHA512 9b23acb043816ab48a3bb36bfe97d85eb05f50883a171d446868f033e8b78c5ee9e1975e98479615744ec8458a0068329135b2343ca30b18f9015ec0d8b9555b WHIRLPOOL dbd2983f86a470caaadb0c4343c82d99dd722f233967493b5e8690b979146613df58aa4edbfbb5d9ab812a94158ef8f5f513cc360477c13b513cfa745d330554
+MISC metadata.xml 253 SHA256 d82c33ef453113a5c1ebe250dcba373c22934a69b0a86c6ab15a5ca589c25b91 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555 WHIRLPOOL e5aee23acff864609953a1e4de768f0e4aef704b44c53c021f28573e1ca5c99f1a46d92935ecec2449f7b4419a36d8373127d0ecfa8d7bae72d835e1839eb3f8
diff --git a/sys-apps/iucode_tool/files/0001-support-musl-uclibc-argp-standalone.patch b/sys-apps/iucode_tool/files/0001-support-musl-uclibc-argp-standalone.patch
new file mode 100644
index 0000000..ec1259b
--- /dev/null
+++ b/sys-apps/iucode_tool/files/0001-support-musl-uclibc-argp-standalone.patch
@@ -0,0 +1,39 @@
+From c0d07bbc25eccac80e81b9924d729a95815d035e Mon Sep 17 00:00:00 2001
+From:
+Date: Sun, 25 Jun 2017 14:31:30 -0500
+Subject: [PATCH] iucode-tool needs argp-standalone when used with MUSL,
+ add missing limits.h
+
+---
+ Makefile.am | 2 ++
+ iucode_tool.c | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/Makefile.am b/Makefile.am
+index 415a241..3094caa 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,6 +5,8 @@
+ sbin_PROGRAMS = iucode_tool
+ man_MANS = iucode_tool.8
+
++# Must use standalone on non GLIBC systems
++iucode_tool_LDADD = -largp
+ iucode_tool_SOURCES = intel_microcode.h intel_microcode.c iucode_tool.c
+ EXTRA_DIST = autogen.sh CONTRIBUTING
+
+diff --git a/iucode_tool.c b/iucode_tool.c
+index 0d34427..5948b3f 100644
+--- a/iucode_tool.c
++++ b/iucode_tool.c
+@@ -31,6 +31,7 @@
+ #include <dirent.h>
+ #include <time.h>
+ #include <cpuid.h>
++#include <limits.h>
+
+ #include "intel_microcode.h"
+
+--
+2.13.2
+
diff --git a/sys-apps/iucode_tool/iucode_tool-2.1.2.ebuild b/sys-apps/iucode_tool/iucode_tool-2.1.2.ebuild
new file mode 100644
index 0000000..345e6a3
--- /dev/null
+++ b/sys-apps/iucode_tool/iucode_tool-2.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+WANT_AUTOMAKE="1.14"
+inherit autotools
+
+DESCRIPTION="tool to manipulate Intel X86 and X86-64 processor microcode update collections"
+HOMEPAGE="https://gitlab.com/iucode-tool/"
+SRC_URI="https://gitlab.com/iucode-tool/releases/raw/master/${PN/_/-}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/argp-standalone"
+
+PATCHES=(
+ "${FILESDIR}"/0001-support-musl-uclibc-argp-standalone.patch
+)
+
+S="${WORKDIR}/${PN/_/-}-${PV}"
diff --git a/sys-apps/iucode_tool/metadata.xml b/sys-apps/iucode_tool/metadata.xml
new file mode 100644
index 0000000..56c1244
--- /dev/null
+++ b/sys-apps/iucode_tool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+</pkgmetadata>