summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/hexchat/Manifest2
-rw-r--r--net-irc/hexchat/hexchat-2.10.2.ebuild171
2 files changed, 173 insertions, 0 deletions
diff --git a/net-irc/hexchat/Manifest b/net-irc/hexchat/Manifest
new file mode 100644
index 0000000..7ff6f39
--- /dev/null
+++ b/net-irc/hexchat/Manifest
@@ -0,0 +1,2 @@
+DIST hexchat-2.10.2.tar.xz 1529732 SHA256 87ebf365c576656fa3f23f51d319b3a6d279e4a932f2f8961d891dd5a5e1b52c SHA512 799be6ca02d4f7bad98c005e0fb7dba151717b52841d7f2dd3ed86b80a20de934825a1e58aab4621ac751a605103e68e368a95e9709c48f52b9e5333e5e290ab WHIRLPOOL 5d8dcd59941a145544bbde2e761db092e801036d6879a0eb3a8b48ece43c02c78df88c889304ac1b4594e89cd68fccc02cd1239d6b60b4a0c13a5156f28154a7
+EBUILD hexchat-2.10.2.ebuild 4455 SHA256 b92137efe4f2c499722db65a926faa7b461abd3529f6a02c8c2903e840ca4e80 SHA512 6b7a1f0f3de64a6fb3aa5a1005824f3097b95c9bf1d5a1a71cdb3e47cf62ac45220a7a2a50408f7ad9e02cc0ddea1dcb1fdb1a52b3c71f584f7e78c00e433600 WHIRLPOOL 7886635e8bad1ce14ce985340278a10212f13e0a2bc1098fe6801b6fb24c3f603500e55cf45c1a24a62d8fc52acf9c5524c844b716fe725a44b449a8e0a87f6a
diff --git a/net-irc/hexchat/hexchat-2.10.2.ebuild b/net-irc/hexchat/hexchat-2.10.2.ebuild
new file mode 100644
index 0000000..f4e4f69
--- /dev/null
+++ b/net-irc/hexchat/hexchat-2.10.2.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/hexchat/hexchat-2.10.1.ebuild,v 1.6 2014/11/21 12:28:37 klausman Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+inherit eutils fdo-mime gnome2-utils mono-env multilib python-single-r1
+
+DESCRIPTION="Graphical IRC client based on XChat"
+HOMEPAGE="http://hexchat.github.io/"
+SRC_URI="http://dl.hexchat.org/hexchat/${P}.tar.xz"
+
+LICENSE="GPL-2 plugin-fishlim? ( MIT )"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux"
+IUSE="dbus +gtk ipv6 libcanberra libnotify libproxy nls ntlm perl +plugins plugin-checksum plugin-doat plugin-fishlim plugin-sysinfo python spell ssl theme-manager"
+REQUIRED_USE="plugins? ( python? ( ${PYTHON_REQUIRED_USE} ) )"
+
+DEPEND="dev-libs/glib:2
+ dbus? ( >=dev-libs/dbus-glib-0.98 )
+ gtk? ( x11-libs/gtk+:2 )
+ libcanberra? ( media-libs/libcanberra )
+ libproxy? ( net-libs/libproxy )
+ libnotify? ( x11-libs/libnotify )
+ nls? ( virtual/libintl )
+ ntlm? ( net-libs/libntlm )
+ plugins? (
+ perl? ( >=dev-lang/perl-5.8.0 )
+ plugin-sysinfo? ( sys-apps/pciutils )
+ python? ( ${PYTHON_DEPS} )
+ )
+ spell? ( app-text/iso-codes )
+ ssl? ( dev-libs/openssl:0 )
+ theme-manager? ( dev-lang/mono )"
+RDEPEND="${DEPEND}
+ spell? ( app-text/enchant )"
+DEPEND="${DEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( dev-util/intltool )
+ theme-manager? ( dev-util/monodevelop )"
+
+pkg_setup() {
+ use plugins && use python && python-single-r1_pkg_setup
+ if use theme-manager ; then
+ mono-env_pkg_setup
+ export XDG_CACHE_HOME="${T}/.cache"
+ fi
+
+ if use !plugins ; then
+ local myplugins
+
+ use perl && myplugins+="perl\n"
+ use python && myplugins+="python\n"
+ use plugin-checksum && myplugins+="plugin-checksum\n"
+ use plugin-doat && myplugins+="plugin-doat\n"
+ use plugin-fishlim && myplugins+="plugin-fishlim\n"
+ use plugin-sysinfo && myplugins+="plugin-sysinfo\n"
+
+ if [[ ${myplugins} ]] ; then
+ ewarn "The following plugins/interfaces have been disabled, because"
+ ewarn "\"plugins\" USE flag is disabled. Check metadata.xml"
+ ewarn "to get more information or run \"equery u hexchat\"."
+ ewarn "\n${myplugins}"
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable libproxy socks) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ $(use_enable gtk gtkfe) \
+ $(use_enable !gtk textfe) \
+ $(usex plugins \
+ "$(usex python "--enable-python=${EPYTHON}" "--disable-python")" \
+ "--disable-python" \
+ ) \
+ $(usex plugins \
+ "$(use_enable perl)" \
+ "--disable-perl" \
+ ) \
+ $(use_enable plugins plugin) \
+ $(usex plugins \
+ "$(use_enable plugin-checksum checksum)" \
+ "--disable-checksum" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-doat doat)" \
+ "--disable-doat" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-fishlim fishlim)" \
+ "--disable-fishlim" \
+ ) \
+ $(usex plugins \
+ "$(use_enable plugin-sysinfo sysinfo)" \
+ "--disable-sysinfo" \
+ ) \
+ $(use_enable dbus) \
+ $(use_enable libnotify) \
+ $(use_enable libcanberra) \
+ $(use_enable ntlm) \
+ $(use_enable libproxy) \
+ $(use_enable spell isocodes) \
+ --enable-minimal-flags \
+ $(use_with theme-manager)
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ UPDATE_ICON_CACHE=true \
+ UPDATE_MIME_DATABASE=true \
+ UPDATE_DESKTOP_DATABASE=true \
+ install
+ dodoc readme.md
+ prune_libtool_files --all
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ einfo
+ else
+ einfo
+ elog "You have disabled the gtk USE flag. This means you don't have"
+ elog "the GTK-GUI for HexChat but only a text interface called \"hexchat-text\"."
+ elog
+ fi
+
+ if use theme-manager ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ elog "Themes are available at:"
+ elog " http://hexchat.org/themes.html"
+ elog
+ fi
+
+ einfo
+ elog "optional dependencies:"
+ elog " media-sound/sox (sound playback if you don't have libcanberra"
+ elog " enabled)"
+ elog " x11-plugins/hexchat-javascript (javascript support)"
+ elog " x11-themes/sound-theme-freedesktop (default BEEP sound,"
+ elog " needs libcanberra enabled)"
+ einfo
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_icon_cache_update
+ fi
+
+ if use theme-manager ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ fi
+}