summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-wireless/lorcon/Manifest4
-rw-r--r--net-wireless/lorcon/files/0001-Add-missing-sys-types.h.patch26
-rw-r--r--net-wireless/lorcon/lorcon-0.0_p20150109.ebuild75
-rw-r--r--net-wireless/lorcon/metadata.xml8
4 files changed, 0 insertions, 113 deletions
diff --git a/net-wireless/lorcon/Manifest b/net-wireless/lorcon/Manifest
deleted file mode 100644
index e86a6ef..0000000
--- a/net-wireless/lorcon/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX 0001-Add-missing-sys-types.h.patch 835 BLAKE2B a5330be7505cdc7db521ed8149dd3b36325df05ba3edc70ae8004f573e70ec2093c2c00fe78bff8094b48a9bceb7b3efdc65d14839cef0b4a6a9c760145ed7d2 SHA512 698b251d809eecc51b01e8117b95c0c1346a60f8a4d08b95592545a4284afaea2dae7fbb6d356fe1d8533d2ab1513fb1e69b3755b3f0575dab27786c7d454903
-DIST lorcon-0.0_p20150109.tar.xz 259788 BLAKE2B e3bd188642f7ef49fa3b7361bd659fdd47d6449598b5248412ad3d8e85e5d0b9c0f8d73fdcd3d0822f19a0d069bf0eeb832bed7bb38c418970d617c03387d1ce SHA512 acbd88477317475ca8555d579a1483ea5e5d9eac0f86ef7bde2592e007025070ca56c6cd43e814560e28165ac7b40bd86f2703a466faeca1619b8373dc2b625b
-EBUILD lorcon-0.0_p20150109.ebuild 1399 BLAKE2B 95285b7a8a94be649324e7c7c97dfdc8268c9b48eb99f3d1859943d38e4a9ab42ddcd5496e2a382163ef99d978ac623b195f0c89ccc09412c17246e2d4e418a8 SHA512 d87f5c602e704c9f96299c4e1ab89c7c7ffa990514d2f3b49a2aa95e70c4324f4894d8c59b1810278ea9f903036bf24335da54a9a51b2d37b5b04389b312f641
-MISC metadata.xml 241 BLAKE2B 31d2e88c810d3facda6587f93bdc429e66b6ed90dc2c019dac1ece6da620b74dc4db8907a25d6559ff7a027f6b267774016686a56c5a5e67da4fbfa3cae7be6e SHA512 d308ccef737c1776c2d77c0761996ef272a5866f5d9ceeda4dd4ceede851a145f76281a29b4c4b154e5b10f1d57c9344010bfcf75ba52fb3f1b34a58e3c2053f
diff --git a/net-wireless/lorcon/files/0001-Add-missing-sys-types.h.patch b/net-wireless/lorcon/files/0001-Add-missing-sys-types.h.patch
deleted file mode 100644
index 3387149..0000000
--- a/net-wireless/lorcon/files/0001-Add-missing-sys-types.h.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 6e12927f734355f3f038719eba3fe068073b4b1b Mon Sep 17 00:00:00 2001
-From: "Jory A. Pratt" <anarchy@gentoo.org>
-Date: Tue, 12 Jun 2018 21:33:54 -0500
-Subject: [PATCH] Add missing sys/types.h
-
-Signed-off-by: Jory A. Pratt <anarchy@gentoo.org>
----
- lorcon_packasm.h | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/lorcon_packasm.h b/lorcon_packasm.h
-index 4dc91e7..a2fd4a3 100644
---- a/lorcon_packasm.h
-+++ b/lorcon_packasm.h
-@@ -155,6 +155,8 @@ void lcpa_free(struct lcpa_metapack *in_head);
- /* Get the size of an assembled LCPA packet */
- int lcpa_size(struct lcpa_metapack *in_head);
-
-+#include <sys/types.h>
-+
- /* Freeze a LCPA fragment packet into a bytestream. The caller is responsible
- * for providing a bytestream of sufficient length. */
- void lcpa_freeze(struct lcpa_metapack *in_head, u_char *bytes);
---
-2.17.1
-
diff --git a/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild b/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
deleted file mode 100644
index a71f624..0000000
--- a/net-wireless/lorcon/lorcon-0.0_p20150109.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit distutils-r1
-
-DESCRIPTION="A generic library for injecting 802.11 frames"
-HOMEPAGE="http://802.11ninja.net/lorcon"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://code.google.com/p/lorcon/"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
- KEYWORDS="amd64 arm ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="python"
-
-DEPEND="
- python? ( ${PYTHON_DEPS} )
- dev-libs/libnl:3=
- net-libs/libpcap"
-RDEPEND="${DEPEND}"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-S="${WORKDIR}"/${P}
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git-r3_src_unpack
- cp -R "${S}/" "${WORKDIR}/all"
- fi
- default_src_unpack
- cd ${S}
- epatch "${FILESDIR}/0001-Add-missing-sys-types.h.patch"
-}
-
-src_prepare() {
- sed -i 's#<lorcon2/lorcon.h>#"../lorcon.h"#' pylorcon2/PyLorcon2.c
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- default_src_configure
-}
-
-src_compile() {
- default_src_compile
- if use python; then
- LDFLAGS+=" -L${S}/.libs/"
- cd pylorcon2 || die
- distutils-r1_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${ED}" install
- if use python; then
- cd pylorcon2 || die
- distutils-r1_src_install
- fi
-}
-
-src_test() {
- :
-}
diff --git a/net-wireless/lorcon/metadata.xml b/net-wireless/lorcon/metadata.xml
deleted file mode 100644
index 0bd1717..0000000
--- a/net-wireless/lorcon/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
-<email>zerochaos@gentoo.org</email>
-<name>Rick Farina</name>
-</maintainer>
-</pkgmetadata>