summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/plymouth/ChangeLog10
-rw-r--r--sys-boot/plymouth/Manifest4
-rw-r--r--sys-boot/plymouth/metadata.xml11
-rw-r--r--sys-boot/plymouth/plymouth-0.6.0.ebuild35
4 files changed, 60 insertions, 0 deletions
diff --git a/sys-boot/plymouth/ChangeLog b/sys-boot/plymouth/ChangeLog
new file mode 100644
index 0000000..1f0ba32
--- /dev/null
+++ b/sys-boot/plymouth/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-boot/plymouth
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*plymouth-0.6.0 (21 Jul 2009)
+
+ 21 Jul 2009; Thilo Bangert <bangert@gentoo.org> +plymouth-0.6.0.ebuild,
+ +metadata.xml:
+ initial import - plymouth: graphical boot splash
+
diff --git a/sys-boot/plymouth/Manifest b/sys-boot/plymouth/Manifest
new file mode 100644
index 0000000..9e3aa3b
--- /dev/null
+++ b/sys-boot/plymouth/Manifest
@@ -0,0 +1,4 @@
+DIST plymouth-0.6.0.tar.bz2 521440 RMD160 2c47420b22b87e4b6e38818630b9157064a53416 SHA1 5ea67d87e8b291cb626dbe02bc5dee522a9ccf02 SHA256 66f80796b4cf0dfacfce77ce6b3f7338e1327be39758717b0e03c1b2e20b1d13
+EBUILD plymouth-0.6.0.ebuild 595 RMD160 f4cfa7e2bfc58b87781b714a4fb5f6be0328f868 SHA1 34d006a1c3c38ffbdf2bbe8d546c468f260439ac SHA256 3fe907b41457fa2c4b30277fefb7999715636e87d2e12d14f1d0f626b8778916
+MISC ChangeLog 292 RMD160 8b4f04626fe8223a12579546f46a58185579aa13 SHA1 d281f8e4810d507d2461639b400947443aaff1d5 SHA256 17dae46f6ff522f2a7756ddb72dfb870b051ebfac87e53ee5d176285eed2ff4d
+MISC metadata.xml 270 RMD160 9c2104f04ac0f50725c6cf3795c09131d72ce3bf SHA1 941e733149edcf87254edcbd640a14ae231d85f8 SHA256 85316efdbdcdb8067fb12b8363283da30f0463c98daecf1d786936cc8e55713c
diff --git a/sys-boot/plymouth/metadata.xml b/sys-boot/plymouth/metadata.xml
new file mode 100644
index 0000000..d0cbf46
--- /dev/null
+++ b/sys-boot/plymouth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>bangert@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/sys-boot/plymouth/plymouth-0.6.0.ebuild b/sys-boot/plymouth/plymouth-0.6.0.ebuild
new file mode 100644
index 0000000..852765f
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-boot/dracut"
+
+
+src_prepare() {
+
+ eautoreconf
+
+}
+
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ #work around qa warning
+ rm "${D}"/lib/libply.la
+ rm "${D}"/lib/libply.a
+}