summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/libgcal/libgcal-0.9.6.ebuild')
-rw-r--r--app-pda/libgcal/libgcal-0.9.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-pda/libgcal/libgcal-0.9.6.ebuild b/app-pda/libgcal/libgcal-0.9.6.ebuild
new file mode 100644
index 0000000..67d31b8
--- /dev/null
+++ b/app-pda/libgcal/libgcal-0.9.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils
+
+DESCRIPTION="C/C++ interface to the Google Data API"
+HOMEPAGE="http://code.google.com/p/libgcal/"
+SRC_URI="http://libgcal.googlecode.com/files/$P.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RDEPEND="app-misc/ca-certificates
+ dev-libs/libxml2
+ net-misc/curl[ssl]"
+DEPEND="${RDEPEND}
+ test? (
+ >=app-pda/libopensync-0.39
+ dev-libs/check
+ )"
+
+#testfailures enmasse - fixes welcome
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use_enable test TESTS)"
+ cmake-utils_src_configure
+}