summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/firmwarekit/firmwarekit-2.ebuild')
-rw-r--r--dev-util/firmwarekit/firmwarekit-2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-util/firmwarekit/firmwarekit-2.ebuild b/dev-util/firmwarekit/firmwarekit-2.ebuild
deleted file mode 100644
index 9b139a6..0000000
--- a/dev-util/firmwarekit/firmwarekit-2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-MY_P="linuxfirmwarekit"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="The Linux-ready Firmware Developer Kit is a tool to test how well
-Linux works together with the firmware (BIOS or EFI) of your machine."
-HOMEPAGE="http://www.linuxfirmwarekit.org/"
-SRC_URI="http://www.linuxfirmwarekit.org/download/${PN}-r${PV}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="1"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=">=dev-libs/glib-2
- sys-libs/slang
- dev-libs/newt"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch ${FILESDIR}/Makefile-no-externals.diff
- epatch ${FILESDIR}/main.c-fix-plugins-dir.diff
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- dolib.so libstandalone.so
- dobin biostest
-
- exeinto /usr/libexec/firmwarekit/plugins
- doexe plugins/*
-
- insinto /usr/libexec/firmwarekit/shelltools
- doins shelltools/*
-
- dodoc Documentation/*
- docinto TestsInfo
- dodoc Documentation/TestsInfo/*
-}
-