summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/plymouth/plymouth-0.6.0.ebuild')
-rw-r--r--sys-boot/plymouth/plymouth-0.6.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-boot/plymouth/plymouth-0.6.0.ebuild b/sys-boot/plymouth/plymouth-0.6.0.ebuild
new file mode 100644
index 0000000..852765f
--- /dev/null
+++ b/sys-boot/plymouth/plymouth-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="Graphical boot animation (splash) and logger"
+HOMEPAGE="http://cgit.freedesktop.org/plymouth/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-boot/dracut"
+
+
+src_prepare() {
+
+ eautoreconf
+
+}
+
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ #work around qa warning
+ rm "${D}"/lib/libply.la
+ rm "${D}"/lib/libply.a
+}