summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-04-14 12:47:35 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-04-14 12:47:45 -0400
commit1fffb83b7e5bf3d25e7a5427789a4eca89a02e08 (patch)
tree4086c483d2d47057db1be44e46601380e86c401f /dev-util/elfsh/elfsh-0.65_rc1.ebuild
parentdev-util/eresi: scavenged from ::sunrise, bug #253436 (diff)
downloadblueness-1fffb83b7e5bf3d25e7a5427789a4eca89a02e08.tar.gz
blueness-1fffb83b7e5bf3d25e7a5427789a4eca89a02e08.tar.bz2
blueness-1fffb83b7e5bf3d25e7a5427789a4eca89a02e08.zip
dev-util{elfsh,eresi}: removeHEADmaster
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'dev-util/elfsh/elfsh-0.65_rc1.ebuild')
-rw-r--r--dev-util/elfsh/elfsh-0.65_rc1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-util/elfsh/elfsh-0.65_rc1.ebuild b/dev-util/elfsh/elfsh-0.65_rc1.ebuild
deleted file mode 100644
index 4b481d8..0000000
--- a/dev-util/elfsh/elfsh-0.65_rc1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="scripting language to modify ELF binaries"
-HOMEPAGE="http://www.eresi-project.org/"
-SRC_URI="mirror://gentoo/${P}.zip"
-#http://www.eresi-project.org/browser/tags/elfsh_0_65rc1
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="readline"
-
-DEPEND=">=dev-libs/expat-1.95
- readline? ( sys-libs/readline )
- app-arch/unzip
- dev-libs/libhash"
-RDEPEND=""
-
-S="${WORKDIR}/tags/elfsh_0_65rc1"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e 's: -O2 : :g' \
- -e "s: -g3 : ${CFLAGS} :" \
- -e "/^LDFLAGS/s:=:=${LDFLAGS} :" \
- $(find -name Makefile) \
- || die
- chmod +x configure
-}
-
-src_compile() {
- local bits
- touch foo.c && $(tc-getCC) -c foo.c -o foo.o || die
- case $(file foo.o) in
- *64-bit*) bits=64;;
- *32-bit*) bits=32;;
- *) die "unknown bits: $(file foo.o)";;
- esac
- # not an autoconf script
- ./configure \
- $([[ ${bits} == "64" ]] && echo "--enable-m64") \
- --enable-${bits} \
- $(use_enable readline) \
- || die
- # emacs does not have to be a requirement.
- emake ETAGS=echo || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "install failed"
- dodoc README.FIRST doc/AUTHOR doc/CREDITS doc/Changelog doc/*.txt
- doman doc/*.1
-}