summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorlayman <layman@localhost>2014-01-20 18:56:03 -0500
committerlayman <layman@localhost>2014-01-20 18:56:03 -0500
commit0453f0bda2f4ca9b025b954af294268dfea98590 (patch)
tree62c7f78aa1118cd39b40156af524320815d1fa44 /sys-apps/getent/getent-9999.ebuild
parentnet-p2p/*coin: moved to tree (diff)
downloadblueness-0453f0bda2f4ca9b025b954af294268dfea98590.tar.gz
blueness-0453f0bda2f4ca9b025b954af294268dfea98590.tar.bz2
blueness-0453f0bda2f4ca9b025b954af294268dfea98590.zip
sys-apps/getent: breakout getent from uclibc, bug #498394
Package-Manager: portage-2.2.7 Manifest-Sign-Key: 0xF52D4BBA
Diffstat (limited to 'sys-apps/getent/getent-9999.ebuild')
-rw-r--r--sys-apps/getent/getent-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/getent/getent-9999.ebuild b/sys-apps/getent/getent-9999.ebuild
new file mode 100644
index 0000000..ca09397
--- /dev/null
+++ b/sys-apps/getent/getent-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+DESCRIPTION="Script to emulate the behavior of glibc's getent utility"
+HOMEPAGE="http://www.uclibc.org/"
+SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+
+DEPEND="
+ !sys-libs/glibc
+ !<=sys-libs/uclibc-0.9.33.2-r9
+"
+
+src_unpack() {
+ mkdir ${P}
+ cp "${DISTDIR}"/${PN} ${P}
+}
+
+src_install() {
+ dobin getent
+}