summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/elfsh/files')
-rw-r--r--dev-util/elfsh/files/0.51_beta3-gentoo.patch63
-rw-r--r--dev-util/elfsh/files/elfsh-0.51_beta3-glibc210.patch70
2 files changed, 0 insertions, 133 deletions
diff --git a/dev-util/elfsh/files/0.51_beta3-gentoo.patch b/dev-util/elfsh/files/0.51_beta3-gentoo.patch
deleted file mode 100644
index 26c4f7b..0000000
--- a/dev-util/elfsh/files/0.51_beta3-gentoo.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -ur elfsh-0.51b3.orig/Makefile elfsh-0.51b3/Makefile
---- elfsh-0.51b3.orig/Makefile 2004-09-20 22:20:22.152723392 -0400
-+++ elfsh-0.51b3/Makefile 2004-09-20 22:21:37.270303784 -0400
-@@ -5,12 +5,14 @@
- ## Last update Sun May 25 18:12:43 2003 mayhem
- ##
-
-+DESTDIR = /
-+PREFIX = $(DESTDIR)/usr
- RM = rm -f
- ETAGS = etags
--MODPATH = /usr/share/elfsh/
--BINPATH = /usr/bin
--LIBPATH = /usr/lib/
--INCPATH = /usr/include/
-+BINPATH = $(PREFIX)/bin
-+LIBPATH = $(PREFIX)/lib
-+INCPATH = $(PREFIX)/include
-+MODPATH = $(LIBPATH)/elfsh
-
- all :
- @echo 'Builting libelfsh...'
-@@ -32,14 +34,15 @@
- #$(MAKE) -s tags
-
- install : mod_install
-+ @mkdir -p $(BINPATH) $(LIBPATH) $(INCPATH)
- @cp vm/elfsh $(BINPATH)/
- @cp libelfsh/libelfsh.a libelfsh/libelfsh.so $(LIBPATH)
- @cp libelfsh/include/libelfsh*.h $(INCPATH)
-- @chmod 755 $(BINPATH)/elfsh $(LIBPATH)libelfsh.so $(LIBPATH)libelfsh.a $(INCPATH)libelfsh*.h
-+ @chmod 755 $(BINPATH)/elfsh $(LIBPATH)/libelfsh.so
- @echo 'ELFsh and Libelfsh installed successfully .'
-
- mod_install:
-- @mkdir $(MODPATH) 2>/dev/null || true
-+ @mkdir -p $(MODPATH)
- @cp modules/*.so $(MODPATH)
- @chmod -R 755 $(MODPATH)
-
-diff -ur elfsh-0.51b3.orig/vm/Makefile elfsh-0.51b3/vm/Makefile
---- elfsh-0.51b3.orig/vm/Makefile 2004-09-20 22:20:22.117728712 -0400
-+++ elfsh-0.51b3/vm/Makefile 2004-09-20 22:22:17.807141248 -0400
-@@ -13,6 +13,7 @@
- #DLOPT_linux-gnu = -ldl
- #DLOPT_solaris = -ldl
- #EXTRAOPT = -lefence
-+EXTRAOPT = -ldl
-
- # Uncomment that to use libasm
- #ASMOPT = -DUSE_LIBASM
-diff -ur elfsh-0.51b3.orig/vm/include/elfsh.h elfsh-0.51b3/vm/include/elfsh.h
---- elfsh-0.51b3.orig/vm/include/elfsh.h 2004-09-20 22:20:22.116728864 -0400
-+++ elfsh-0.51b3/vm/include/elfsh.h 2004-09-20 22:20:22.358692080 -0400
-@@ -94,7 +94,7 @@
- #define ELFSH_SHELL "/bin/bash"
- #define ELFSH_INIT "elfsh_init"
- #define ELFSH_FINI "elfsh_fini"
--#define ELFSH_MODPATH "/usr/share/elfsh/"
-+#define ELFSH_MODPATH "/usr/lib/elfsh/"
-
- /* For elfsh/elfsh/disasm.c:display_object() */
- #define ELFSH_HEXA_VIEW 0
diff --git a/dev-util/elfsh/files/elfsh-0.51_beta3-glibc210.patch b/dev-util/elfsh/files/elfsh-0.51_beta3-glibc210.patch
deleted file mode 100644
index 2e83c93..0000000
--- a/dev-util/elfsh/files/elfsh-0.51_beta3-glibc210.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff -NrU5 elfsh-0.51b3.original/modules/modgraph.c elfsh-0.51b3/modules/modgraph.c
---- elfsh-0.51b3.original/modules/modgraph.c 2009-07-22 23:17:51.000000000 -0600
-+++ elfsh-0.51b3/modules/modgraph.c 2009-07-22 23:33:28.000000000 -0600
-@@ -181,11 +181,11 @@
- }
- }
- else
- {
- name = elfsh_reverse_metasym(world.current, blk->vaddr, &off);
-- dprintf(fd, "%s_%08x", name, off);
-+ d_printf(fd, "%s_%08x", name, off);
-
- }
- free(buffer);
- world.state.vm_quiet = vm_quiet;
- }
-diff -NrU5 elfsh-0.51b3.original/vm/disasm.c elfsh-0.51b3/vm/disasm.c
---- elfsh-0.51b3.original/vm/disasm.c 2009-07-22 23:17:51.000000000 -0600
-+++ elfsh-0.51b3/vm/disasm.c 2009-07-22 23:33:53.000000000 -0600
-@@ -80,30 +80,30 @@
-
- /* Are we in quiet mode ? */
- if (world.state.vm_quiet)
- {
- snprintf(buf, sizeof(buf), " %08X %s + %u", vaddr + index, name, nindex);
-- dprintf(fd, "%-40s %-30s ", buf, s);
-+ d_printf(fd, "%-40s %-30s ", buf, s);
- }
- else
- {
- snprintf(buf, sizeof(buf), " %08X [foff: %u] %s + %u",
- vaddr + index, foffset + index, name, nindex);
-- dprintf(fd, "%-60s %-50s ", buf, s);
-+ d_printf(fd, "%-60s %-50s ", buf, s);
- }
-
- /* Print bytes in hexa for this instruction */
- ret = asm_instr_len(&ptr);
- if (!ret)
- ret++;
-
- if (!world.state.vm_quiet)
- for (idx_bytes = 0; idx_bytes < ret; idx_bytes++)
-- dprintf(fd, "%c%c ",
-+ d_printf(fd, "%c%c ",
- base[(buff[index + idx_bytes] >> 4) & 0x0F],
- base[buff[index + idx_bytes] & 0x0F]);
-- dprintf(fd, "\n");
-+ d_printf(fd, "\n");
- return (ret);
- }
- #endif /* USE_LIBASM */
-
-
-diff -NrU5 elfsh-0.51b3.original/vm/include/elfsh.h elfsh-0.51b3/vm/include/elfsh.h
---- elfsh-0.51b3.original/vm/include/elfsh.h 2009-07-22 23:17:51.000000000 -0600
-+++ elfsh-0.51b3/vm/include/elfsh.h 2009-07-22 23:22:30.000000000 -0600
-@@ -469,11 +469,11 @@
- int vm_getsort(u_int index, u_int argc, char **argv);
- int vm_getdisasm(u_int index, u_int argc, char **argv);
- int vm_gethexa(u_int index, u_int argc, char **argv);
- int vm_getvarparams(u_int index, u_int argc, char **argv);
-
--int dprintf(int fd, char *format, ...);
-+int d_printf(int fd, char *format, ...);
-
- /* Libasm resolve handler */
- void do_resolve(void *data, u_int vaddr, char *, u_int);
- u_int display_instr(int, u_int, u_int, u_int, u_int,
- char *, u_int, char *);