summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/getent/getent-0.ebuild')
-rw-r--r--sys-apps/getent/getent-0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/getent/getent-0.ebuild b/sys-apps/getent/getent-0.ebuild
new file mode 100644
index 0000000..6307204
--- /dev/null
+++ b/sys-apps/getent/getent-0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+DESCRIPTION="Script to emulate the behavior of glibc's getent utility"
+HOMEPAGE="http://www.uclibc.org/"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI="http://git.uclibc.org/uClibc/plain/extra/scripts/${PN}"
+ MY_P=${PN}
+else
+ SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}"
+ KEYWORDS="~amd64 ~arm ~m68k ~mips ~ppc ~sh ~sparc ~x86"
+ MY_P=${P}
+fi
+
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+DEPEND="
+ !sys-libs/glibc
+ !<=sys-libs/uclibc-0.9.33.2-r9
+"
+
+src_unpack() {
+ mkdir ${P}
+ cp "${DISTDIR}"/${MY_P} ${P}/${PN}
+}
+
+src_install() {
+ dobin getent
+}