summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'apps/dev-eiffel/eiffelstudio/eiffelstudio-6.4.79451.ebuild')
-rw-r--r--apps/dev-eiffel/eiffelstudio/eiffelstudio-6.4.79451.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.4.79451.ebuild b/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.4.79451.ebuild
deleted file mode 100644
index 8e15800..0000000
--- a/apps/dev-eiffel/eiffelstudio/eiffelstudio-6.4.79451.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-KEYWORDS="-* ~amd64 ~x86"
-
-MAIN_PV="${PV%.*}"
-MAIN_PV="${MAIN_PV/./}"
-SUB_PV="${PV##*.}"
-
-DESCRIPTION="EiffelStudio IDE."
-HOMEPAGE="http://${PN}.sourceforge.net/"
-SRC_URI="x86? ( mirror://sourceforge/${PN}/Eiffel${MAIN_PV}_gpl_${SUB_PV}-linux-x86.tar.bz2 )
- amd64? ( mirror://sourceforge/${PN}/Eiffel${MAIN_PV}_gpl_${SUB_PV}-linux-x86-64.tar.bz2 )"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="precompile"
-
-DEPEND="sys-devel/gcc
- dev-util/bsdiff
- >=x11-libs/gtk+-2.6.0"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/Eiffel${MAIN_PV}"
-
-src_compile() {
- if use amd64 ; then
- ISE_PLATFORM="linux-x86-64"
- else
- ISE_PLATFORM="linux-x86"
- fi
-
- if use precompile ; then
- ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/base.ecf -c_compile -clean || die "precompile failed"
- ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/base-mt.ecf -c_compile -clean || die "precompile failed"
- ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/vision2.ecf -c_compile -clean || die "precompile failed"
- ISE_EIFFEL="${S}" ISE_PLATFORM=${ISE_PLATFORM} studio/spec/${ISE_PLATFORM}/bin/ec -precompile -config precomp/spec/${ISE_PLATFORM}/vision2-mt.ecf -c_compile -clean || die "precompile failed"
- fi
-}
-
-src_install() {
- echo "ISE_EIFFEL=/opt/Eiffel${MAIN_PV}" > "${T}/52${PN}"
- ISE_EIFFEL=/opt/Eiffel${MAIN_PV}
-
- if use amd64 ; then
- echo "ISE_PLATFORM=linux-x86-64" >> "${T}/52${PN}"
- ISE_PLATFORM="linux-x86-64"
- else
- echo "ISE_PLATFORM=linux-x86" >> "${T}/52${PN}"
- ISE_PLATFORM="linux-x86"
- fi
-
- echo "PATH=${ISE_EIFFEL}/studio/spec/${ISE_PLATFORM}/bin" >> "${T}/52${PN}"
-
- doenvd "${T}/52${PN}"
-
- dodir /opt/Eiffel${MAIN_PV}
- mv -f * "${D}"/opt/Eiffel${MAIN_PV}
-}