summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/smbtad/smbtad-1.2.3.ebuild')
-rw-r--r--net-fs/smbtad/smbtad-1.2.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-fs/smbtad/smbtad-1.2.3.ebuild b/net-fs/smbtad/smbtad-1.2.3.ebuild
new file mode 100644
index 0000000..a5fdd87
--- /dev/null
+++ b/net-fs/smbtad/smbtad-1.2.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+inherit cmake-utils
+
+DESCRIPTION="Data receiver of the SMB Traffic Analyzer project"
+HOMEPAGE="http://github.com/hhetter/smbtad"
+SRC_URI="http://morelias.org/smbta/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-util/cmake"
+
+RDEPEND="net-fs/samba[smbtav2]"
+
+DOCS="README AUTHORS"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs} \
+ $(cmake-utils_use debug DEBUG)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd "${FILESDIR}"/smbtad.rc smbtad
+ newconfd dist/smbtad.conf_example smbtad.conf
+
+}