summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-09-20 15:40:32 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-09-20 15:40:51 +0000
commit1759ed18dd6755de915e6371415684a7915457e3 (patch)
treeca5162ba7c59620010f2f9671c7d70898d1471b4 /dev-util/catalyst/catalyst-2.0.6.916.ebuild
parent[dev-util/catalyst] Re-align with gx86 with a few custom mods (diff)
downloaddarkside-1759ed18dd6755de915e6371415684a7915457e3.tar.gz
darkside-1759ed18dd6755de915e6371415684a7915457e3.tar.bz2
darkside-1759ed18dd6755de915e6371415684a7915457e3.zip
[dev-util/catalyst] sync with gx86, style changes
Diffstat (limited to 'dev-util/catalyst/catalyst-2.0.6.916.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
deleted file mode 100644
index 72e134a..0000000
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.2 2011/06/22 19:36:33 sping Exp $
-
-# catalyst-9999 -> latest Git
-# catalyst-VER -> normal catalyst release
-
-EAPI=4
-inherit eutils multilib
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
- inherit git
- SRC_URI=""
- S="${WORKDIR}/${PN}"
- KEYWORDS=""
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-fi
-
-DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="ccache"
-
-DEPEND=""
-RDEPEND="dev-lang/python
- app-crypt/shash
- virtual/cdrtools
- ccache? ( dev-util/ccache )
- ia64? ( sys-fs/dosfstools )
- kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
-src_prepare() {
- epatch "${FILESDIR}"/0001*.patch
-}
-
-src_install() {
- insinto /usr/$(get_libdir)/${PN}
- exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst
- if [[ ${PV} == 9999* ]]; then
- doins -r modules files
- else
- doins -r arch modules livecd
- fi
- for x in targets/*; do
- exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/*
- done
- make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
- insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc
- insinto /usr/share/doc/${PF}/examples
- doins examples/*
- dodoc README ChangeLog AUTHORS
- doman files/catalyst.1
- # Here is where we actually enable ccache
- use ccache && \
- dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
- /etc/catalyst/catalyst.conf
- dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
- /etc/catalyst/catalyst.conf
-}