summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-06-08 18:04:14 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-06-08 18:04:14 +0000
commit1c8b8c332bf5abfbc176554f236f90e4052a9b53 (patch)
tree9fdf632e413ff6229d0c98b2a71b1aff1d58bae2 /dev-util/catalyst/catalyst-2.0.6.916.ebuild
parentRevert "[dev-utils/catalyst]: Apply patch from bug 113298" (diff)
downloaddarkside-1c8b8c332bf5abfbc176554f236f90e4052a9b53.tar.gz
darkside-1c8b8c332bf5abfbc176554f236f90e4052a9b53.tar.bz2
darkside-1c8b8c332bf5abfbc176554f236f90e4052a9b53.zip
[dev-util/catalyst] Cleanup ebuild by migrating to EAPI4 and other improvements
Diffstat (limited to 'dev-util/catalyst/catalyst-2.0.6.916.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild50
1 files changed, 18 insertions, 32 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
index 40ccc18..e3f5bb4 100644
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
@@ -2,19 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.914.ebuild,v 1.1 2011/02/09 20:28:25 armin76 Exp $
+EAPI=4
inherit eutils multilib
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://wolf31o2.org/projects/catalyst"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-#KEYWORDS=""
-RESTRICT=""
IUSE="ccache"
DEPEND=""
@@ -25,41 +22,25 @@ RDEPEND="dev-lang/python
ia64? ( sys-fs/dosfstools )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-pkg_setup() {
- if use ccache ; then
- einfo "Enabling ccache support for catalyst."
- else
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- echo
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
-}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/0001*.patch
}
src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
- doexe catalyst || die "copying catalyst"
- doins -r arch modules livecd || die "copying files"
+ doexe catalyst
+ doins -r arch modules livecd
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
- doexe $x/* || die "copying ${x}"
+ doexe $x/*
done
make_wrapper catalyst /usr/$(get_libdir)/${PN}/catalyst
insinto /etc/catalyst
- doins files/catalyst.conf files/catalystrc || die "copying configuration"
+ doins files/catalyst.conf files/catalystrc
insinto /usr/share/doc/${PF}/examples
- doins examples/* || die
+ doins examples/*
dodoc README ChangeLog AUTHORS
doman files/catalyst.1
# Here is where we actually enable ccache
@@ -71,8 +52,13 @@ src_install() {
}
pkg_postinst() {
- einfo "You can find more information about catalyst by checking out the"
- einfo "catalyst project page at:"
- einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
- echo
+ if ! use ccache ; then
+ ewarn "By default, ccache support for catalyst is disabled."
+ ewarn "If this is not what you intended,"
+ ewarn "then you should add ccache to your USE."
+ fi
+ einfo "The template spec files are now installed by default. You can find"
+ einfo "them under /usr/share/doc/${PF}/examples"
+ einfo "and they are considered to be the authorative source of information"
+ einfo "on catalyst."
}