summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/catalyst/catalyst-2.0.6.916.ebuild')
-rw-r--r--dev-util/catalyst/catalyst-2.0.6.916.ebuild40
1 files changed, 22 insertions, 18 deletions
diff --git a/dev-util/catalyst/catalyst-2.0.6.916.ebuild b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
index e3f5bb4..72e134a 100644
--- a/dev-util/catalyst/catalyst-2.0.6.916.ebuild
+++ b/dev-util/catalyst/catalyst-2.0.6.916.ebuild
@@ -1,17 +1,30 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.914.ebuild,v 1.1 2011/02/09 20:28:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0.6.916.ebuild,v 1.2 2011/06/22 19:36:33 sping Exp $
+
+# catalyst-9999 -> latest Git
+# catalyst-VER -> normal catalyst release
EAPI=4
inherit eutils multilib
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/catalyst.git"
+ inherit git
+ SRC_URI=""
+ S="${WORKDIR}/${PN}"
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wolf31o2.org/sources/${PN}/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+fi
+
DESCRIPTION="release metatool used for creating releases based on Gentoo Linux"
-HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
IUSE="ccache"
DEPEND=""
@@ -22,7 +35,6 @@ RDEPEND="dev-lang/python
ia64? ( sys-fs/dosfstools )
kernel_linux? ( app-misc/zisofs-tools >=sys-fs/squashfs-tools-2.1 )"
-
src_prepare() {
epatch "${FILESDIR}"/0001*.patch
}
@@ -31,7 +43,11 @@ src_install() {
insinto /usr/$(get_libdir)/${PN}
exeinto /usr/$(get_libdir)/${PN}
doexe catalyst
- doins -r arch modules livecd
+ if [[ ${PV} == 9999* ]]; then
+ doins -r modules files
+ else
+ doins -r arch modules livecd
+ fi
for x in targets/*; do
exeinto /usr/$(get_libdir)/${PN}/$x
doexe $x/*
@@ -50,15 +66,3 @@ src_install() {
dosed "s:/usr/lib/catalyst:/usr/$(get_libdir)/catalyst:" \
/etc/catalyst/catalyst.conf
}
-
-pkg_postinst() {
- if ! use ccache ; then
- ewarn "By default, ccache support for catalyst is disabled."
- ewarn "If this is not what you intended,"
- ewarn "then you should add ccache to your USE."
- fi
- einfo "The template spec files are now installed by default. You can find"
- einfo "them under /usr/share/doc/${PF}/examples"
- einfo "and they are considered to be the authorative source of information"
- einfo "on catalyst."
-}