aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-09-04 12:06:47 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-04 12:06:47 -0700
commitb2f39ba59b0e4be93f1e911b591d1e6620a45260 (patch)
treea2f16023fb9366671bebfcb48710d8cc24ea555d /app-admin
parentAdd system-config-httpd (diff)
downloaddberkholz-b2f39ba59b0e4be93f1e911b591d1e6620a45260.tar.gz
dberkholz-b2f39ba59b0e4be93f1e911b591d1e6620a45260.tar.bz2
dberkholz-b2f39ba59b0e4be93f1e911b591d1e6620a45260.zip
system-config-httpd: gentooify
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/system-config-httpd/Manifest12
-rw-r--r--app-admin/system-config-httpd/files/1.3.3-gentooify.patch79
-rw-r--r--app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild6
3 files changed, 93 insertions, 4 deletions
diff --git a/app-admin/system-config-httpd/Manifest b/app-admin/system-config-httpd/Manifest
index f07a0b4..7b1ac45 100644
--- a/app-admin/system-config-httpd/Manifest
+++ b/app-admin/system-config-httpd/Manifest
@@ -1,8 +1,12 @@
+AUX 1.3.3-gentooify.patch 3118 RMD160 9f68958e61ac52a6d889f0334ea57f91d68625f4 SHA1 252d67e354fe2240e273a4b85b28bd82ecd430e3 SHA256 355c7f1ea7691ca6750a17c0d372cc603d22f0f3cc6e2885e5e8f74e542500b7
+MD5 4f9820a39380cb483deeac5cad17a2f9 files/1.3.3-gentooify.patch 3118
+RMD160 9f68958e61ac52a6d889f0334ea57f91d68625f4 files/1.3.3-gentooify.patch 3118
+SHA256 355c7f1ea7691ca6750a17c0d372cc603d22f0f3cc6e2885e5e8f74e542500b7 files/1.3.3-gentooify.patch 3118
DIST system-config-httpd-1.3.3-1.1.1.src.rpm 833094 RMD160 2a96e737d3b1b8ef9128ca149edd46fb60ae3b30 SHA1 db88aee34a952aff5aef69bd8f68535813132d68 SHA256 e52343a1290fd39b0b55fd58ab6961c998104e3423de72e7b2574eb84907d942
-EBUILD system-config-httpd-1.3.3.ebuild 996 RMD160 0c8ed4ff60a5dfc0e88e672fc8ef0f02bd410e2f SHA1 f46b97f9dd93f3792d3b60099e924208138d5176 SHA256 2caad10f63d6586cc6d5a29fef304663013f993a30773261b9e37ecb7987e89e
-MD5 78175fa35ed4c91d325ee3d2aa7932c4 system-config-httpd-1.3.3.ebuild 996
-RMD160 0c8ed4ff60a5dfc0e88e672fc8ef0f02bd410e2f system-config-httpd-1.3.3.ebuild 996
-SHA256 2caad10f63d6586cc6d5a29fef304663013f993a30773261b9e37ecb7987e89e system-config-httpd-1.3.3.ebuild 996
+EBUILD system-config-httpd-1.3.3.ebuild 1085 RMD160 81d7d046ac48d020b9ddeff23827d4857334a47a SHA1 579108516835c3710deee02f34b26d6cd1a3e2e4 SHA256 d1738748211d1c085b1089477c21dfc2103e55196adb9557cbe55ddf12207aeb
+MD5 d3e954efb15ddad1a36551cba6855d8e system-config-httpd-1.3.3.ebuild 1085
+RMD160 81d7d046ac48d020b9ddeff23827d4857334a47a system-config-httpd-1.3.3.ebuild 1085
+SHA256 d1738748211d1c085b1089477c21dfc2103e55196adb9557cbe55ddf12207aeb system-config-httpd-1.3.3.ebuild 1085
MD5 271f6db54f7a01ded6433812c9c276c3 files/digest-system-config-httpd-1.3.3 298
RMD160 556178dd7dd9aa325f569871ea1f3605d39b93e3 files/digest-system-config-httpd-1.3.3 298
SHA256 78a07bfaf5b309e7cb67075a9925a1dcd31e6957a0c7b1262f28f44a7dc61207 files/digest-system-config-httpd-1.3.3 298
diff --git a/app-admin/system-config-httpd/files/1.3.3-gentooify.patch b/app-admin/system-config-httpd/files/1.3.3-gentooify.patch
new file mode 100644
index 0000000..8e0e2eb
--- /dev/null
+++ b/app-admin/system-config-httpd/files/1.3.3-gentooify.patch
@@ -0,0 +1,79 @@
+diff -urN system-config-httpd-1.3.3.orig/src/ApacheBase.py system-config-httpd-1.3.3/src/ApacheBase.py
+--- system-config-httpd-1.3.3.orig/src/ApacheBase.py 2006-09-04 11:57:25.000000000 -0700
++++ system-config-httpd-1.3.3/src/ApacheBase.py 2006-09-04 12:01:10.000000000 -0700
+@@ -4349,7 +4349,7 @@
+
+ # Compute md5sum of currently installed httpd.conf
+ try:
+- rmd5 = hexstr (md5 (open ('/etc/httpd/conf/httpd.conf', 'r').read ()).digest())
++ rmd5 = hexstr (md5 (open ('/etc/apache2/httpd.conf', 'r').read ()).digest())
+ except:
+ rmd5 = ''
+
+@@ -4361,14 +4361,14 @@
+ if omd5 != rmd5:
+ if force:
+ try:
+- os.remove ('/etc/httpd/conf/httpd.conf.bak')
++ os.remove ('/etc/apache2/httpd.conf.bak')
+ except:
+ pass
+ try:
+- os.rename ('/etc/httpd/conf/httpd.conf', '/etc/httpd/conf/httpd.conf.bak')
++ os.rename ('/etc/apache2/httpd.conf', '/etc/apache2/httpd.conf.bak')
+ except:
+ pass
+- open ('/etc/httpd/conf/httpd.conf', 'w').write (result)
++ open ('/etc/apache2/httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+@@ -4377,7 +4377,7 @@
+ else:
+ return -2
+ else:
+- open ('/etc/httpd/conf/httpd.conf', 'w').write (result)
++ open ('/etc/apache2/httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+diff -urN system-config-httpd-1.3.3.orig/src/httpd.conf.xsl system-config-httpd-1.3.3/src/httpd.conf.xsl
+--- system-config-httpd-1.3.3.orig/src/httpd.conf.xsl 2006-09-04 11:57:25.000000000 -0700
++++ system-config-httpd-1.3.3/src/httpd.conf.xsl 2006-09-04 12:00:25.000000000 -0700
+@@ -29,8 +29,8 @@
+ # of the server's control files begin with "/" (or "drive:/" for Win32), the
+ # server will use that explicit path. If the filenames do *not* begin
+ # with "/", the value of ServerRoot is prepended -- so "logs/foo.log"
+-# with ServerRoot set to "/etc/httpd" will be interpreted by the
+-# server as "/etc/httpd/logs/foo.log".
++# with ServerRoot set to "/etc/apache2" will be interpreted by the
++# server as "/etc/apache2/logs/foo.log".
+ #
+
+ ### Section 1: Global Environment
+@@ -203,9 +203,14 @@
+ LoadModule cgi_module modules/mod_cgi.so
+
+ #
+-# Load config files from the config directory "/etc/httpd/conf.d".
++# Load config files from the config directory "/etc/apache2/modules.d".
+ #
+-Include conf.d/*.conf
++Include modules.d/*.conf
++
++#
++# Load config files from the config directory "/etc/apache2/vhosts.d".
++#
++Include vhosts.d/*.conf
+
+ #
+ # ExtendedStatus controls whether Apache will generate "full" status
+@@ -865,7 +870,7 @@
+ # To enable the cache as well, edit and uncomment the following lines:
+ # (no cacheing without CacheRoot)
+ #
+-#CacheRoot "/etc/httpd/proxy"
++#CacheRoot "/etc/apache2/proxy"
+ #CacheSize 5
+ #CacheGcInterval 4
+ #CacheMaxExpire 24
diff --git a/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
index 850722d..2dd5c99 100644
--- a/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
+++ b/app-admin/system-config-httpd/system-config-httpd-1.3.3.ebuild
@@ -34,6 +34,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"