aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@supernova.(none)>2006-09-21 08:18:34 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-21 08:18:34 -0700
commitc483b3143fbc2a72f4ab38bb678fd65deea3cd45 (patch)
treeb84ec0ac6768c870ec61f8779177bcd463ac88e4 /sci-libs
parentghemical: build against mopac7 using gcc-4. (diff)
downloaddberkholz-c483b3143fbc2a72f4ab38bb678fd65deea3cd45.tar.gz
dberkholz-c483b3143fbc2a72f4ab38bb678fd65deea3cd45.tar.bz2
dberkholz-c483b3143fbc2a72f4ab38bb678fd65deea3cd45.zip
Add non-working scipy bump, and new package PyXPlot.
new scipy should work with numpy 1.0* but I can't get it compiling yet. PyXPlot is like gnuplot but produces better graphs.
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/Manifest8
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.5.13
-rw-r--r--sci-libs/scipy/scipy-0.5.1.ebuild132
3 files changed, 143 insertions, 0 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
new file mode 100644
index 0000000..5389c07
--- /dev/null
+++ b/sci-libs/scipy/Manifest
@@ -0,0 +1,8 @@
+DIST scipy-0.5.1.tar.gz 4141008 RMD160 60a184b57f50e9bef78843cbe96542aee43ac386 SHA1 bed9be244fc73c96a252184cfc14653035832f7e SHA256 312e7562aa04923c02c346866e06fd44e4fcf872c518f64c0f9dabece5ff860a
+EBUILD scipy-0.5.1.ebuild 3477 RMD160 0c4f5f4afab1da60fdc83b1a86db6efa61ba7230 SHA1 f50769a4a7e6425f4b1f6e10a86c7dedd13ced04 SHA256 f63e60534ef29311a89186693d4bcf50290929837db0ed1a1ed7d78026b4b444
+MD5 5cae2c5ea9efa2bc32fefb51543c9c34 scipy-0.5.1.ebuild 3477
+RMD160 0c4f5f4afab1da60fdc83b1a86db6efa61ba7230 scipy-0.5.1.ebuild 3477
+SHA256 f63e60534ef29311a89186693d4bcf50290929837db0ed1a1ed7d78026b4b444 scipy-0.5.1.ebuild 3477
+MD5 66932efefabfe718cb3d73282ad705a6 files/digest-scipy-0.5.1 238
+RMD160 390c13d3a30931cde09e3f744f550a00a96ba2bd files/digest-scipy-0.5.1 238
+SHA256 cd9eb7d7e35ce61f15b7489977e02c867e8e2185ed49a1767d6b3e527e4e0bb4 files/digest-scipy-0.5.1 238
diff --git a/sci-libs/scipy/files/digest-scipy-0.5.1 b/sci-libs/scipy/files/digest-scipy-0.5.1
new file mode 100644
index 0000000..08c9806
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.5.1
@@ -0,0 +1,3 @@
+MD5 48442a427f0556ad2ad1721dd62e401c scipy-0.5.1.tar.gz 4141008
+RMD160 60a184b57f50e9bef78843cbe96542aee43ac386 scipy-0.5.1.tar.gz 4141008
+SHA256 312e7562aa04923c02c346866e06fd44e4fcf872c518f64c0f9dabece5ff860a scipy-0.5.1.tar.gz 4141008
diff --git a/sci-libs/scipy/scipy-0.5.1.ebuild b/sci-libs/scipy/scipy-0.5.1.ebuild
new file mode 100644
index 0000000..c396eda
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.5.1.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.4.9.ebuild,v 1.1 2006/06/14 01:09:34 spyderous Exp $
+
+inherit distutils flag-o-matic fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# did not use virtual/blas and virtual/lapack
+# because doc says scipy needs to compile all libraries with the same compiler
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numpy-1.0_beta1
+ sci-libs/blas-atlas
+ sci-libs/blas-config
+ sci-libs/lapack-config
+ sci-libs/lapack-atlas
+ fftw? ( =sci-libs/fftw-2.1* )"
+
+DEPEND="${RDEPEND}"
+
+# install doc claims fftw-2 is faster for complex ffts.
+# wxwindows seems to have disapeared : ?
+# f2py seems to be in numpy.
+
+FORTRAN="g77 gfortran"
+
+pkg_setup() {
+ fortran_pkg_setup
+
+ einfo "Checking active BLAS implementations for ATLAS."
+ blas-config -p
+ if ! blas-config -p | grep "F77 BLAS:" | grep -q -i atlas; then
+ eerror "Your F77 BLAS profile is not set to the ATLAS implementation,"
+ eerror "which is required by ${PN} to compile and run properly."
+ eerror "Use: 'blas-config -f ATLAS' to activate ATLAS."
+ echo
+ bad_profile=1
+ fi
+ if ! blas-config -p | grep "C BLAS:" | grep -q -i atlas; then
+ eerror "Your C BLAS profile is not set to the ATLAS implementation,"
+ eerror "Which is required by ${PN} to compile and run properly."
+ eerror "Use: 'blas-config -c ATLAS' to activate ATLAS."
+ echo
+ bad_profile=1
+ fi
+ einfo "Checking active LAPACK implementation for ATLAS."
+ lapack-config -p
+ if ! lapack-config -p | grep "F77 LAPACK:" | grep -q -i atlas; then
+ eerror "Your F77 LAPACK profile is not set to the ATLAS implementation,"
+ eerror "which is required by ${PN} to compile and run properly."
+ eerror "Use: 'lapack-config ATLAS' to activate ATLAS."
+ bad_profile=1
+ fi
+ if ! [ -z ${bad_profile} ]; then
+ die "Active BLAS/LAPACK implementations are not ATLAS."
+ fi
+
+ # -Wl,-O1 breaks the compilation
+ filter-ldflags -O1
+ filter-ldflags -Wl,-O1
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:/usr/$(get_libdir):" \
+ >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas, pthread" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ fi
+
+ export FFTW3=None
+ if use fftw; then
+ echo "[fftw] " >> site.cfg
+ echo "fftw_libs = rfftw, fftw" >> site.cfg
+ echo "fftw_opt_libs = rfftw_threads, fftw_threads" >> site.cfg
+ else
+ export FFTW=None
+ fi
+}
+
+src_compile() {
+ # Map compilers to what scipy calls them
+ local SCIPY_FC
+ case "${FORTRANC}" in
+ gfortran)
+ SCIPY_FC="gnu95"
+ ;;
+ g77)
+ SCIPY_FC="gnu"
+ ;;
+ g95)
+ SCIPY_FC="g95"
+ ;;
+ ifc|ifort)
+ if use ia64; then
+ SCIPY_FC="intele"
+ else
+ SCIPY_FC="intel"
+ fi
+ ;;
+ *)
+ local msg="Invalid Fortran compiler \'${FORTRANC}\'"
+ eerror "${msg}"
+ die "${msg}"
+ ;;
+ esac
+ distutils_src_compile \
+ config_fc \
+ --fcompiler=${SCIPY_FC} \
+ --opt="${CFLAGS}" \
+ || die "compilation failed"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc *.txt
+}