aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2012-05-10 11:23:11 -0500
committerDonnie Berkholz <dberkholz@gentoo.org>2012-05-10 11:23:11 -0500
commit0758089f42a1ab82d3191f6dc1898ba0e361e8e7 (patch)
treefab681b60ecb0888562c1870601e7a30326a3bec /sci-mathematics
parentscribus: 1.4 was merged to portage, delete outdated stuff. (diff)
downloaddberkholz-0758089f42a1ab82d3191f6dc1898ba0e361e8e7.tar.gz
dberkholz-0758089f42a1ab82d3191f6dc1898ba0e361e8e7.tar.bz2
dberkholz-0758089f42a1ab82d3191f6dc1898ba0e361e8e7.zip
mlpy: bump to 3.5.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mlpy/Manifest4
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild (renamed from sci-mathematics/mlpy/mlpy-2.1.0.ebuild)14
2 files changed, 9 insertions, 9 deletions
diff --git a/sci-mathematics/mlpy/Manifest b/sci-mathematics/mlpy/Manifest
index 2feedf6..6547ed1 100644
--- a/sci-mathematics/mlpy/Manifest
+++ b/sci-mathematics/mlpy/Manifest
@@ -1,2 +1,2 @@
-DIST MLPY-2.1.0.tar.gz 153360 RMD160 196fb0077a715612ceab3a655dcefb77b44ab98c SHA1 b4e0fae9ca2eb635b132a169354ac1c4e0dd718c SHA256 435d5802a94024330c70379cd14267e6f73013b4b6c1df0144ad358c0db721b5
-EBUILD mlpy-2.1.0.ebuild 734 RMD160 55615cd8554af1518f137e07746d7649ddefcb7a SHA1 9a723b633346d03a45809a6fe707e782d63e1fc8 SHA256 2b54b9b168907fe0846f003e18af19886eab1fccef9aeb457ea5106a37683e05
+DIST mlpy-3.5.0.tar.gz 1961206 RMD160 9dfb6387214859993d66db9108d07340aacb35c6 SHA1 32f986f7f0f7cce5c773d2909d34705eab39df16 SHA256 344fa75fbf9f76af72f6a346d5309613defc4d244bac13c218e509a51d68bf6a
+EBUILD mlpy-3.5.0.ebuild 703 RMD160 6f6c60a7754aca31b226896ee66e042aa4f6fe48 SHA1 580706eaac12026714d3ee9c08ba9b40866bf02b SHA256 47802fe8898e6e32a0dc557f326f6b9d263a63d892386699d6c681008be2671a
diff --git a/sci-mathematics/mlpy/mlpy-2.1.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
index 79aaa5e..c5daf07 100644
--- a/sci-mathematics/mlpy/mlpy-2.1.0.ebuild
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -2,23 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=4
+
inherit distutils
-MY_PN="MLPY"
-MY_P=${MY_PN}-${PV}
DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
HOMEPAGE="https://mlpy.fbk.eu/"
-SRC_URI="https://mlpy.fbk.eu/download/src/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"
-RDEPEND=">=sci-libs/gsl-1.8
- >=dev-python/numpy-1.1
- >=virtual/python-2.5"
+RDEPEND=">=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7
+ >=dev-lang/python-2.6"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx )"
-S=${WORKDIR}/${MY_P}
src_install() {
distutils_src_install