aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-twitter/python-twitter-1.1.6.ebuild')
-rw-r--r--dev-python/python-twitter/python-twitter-1.1.6.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/python-twitter/python-twitter-1.1.6.ebuild b/dev-python/python-twitter/python-twitter-1.1.6.ebuild
new file mode 100644
index 0000000..488f736
--- /dev/null
+++ b/dev-python/python-twitter/python-twitter-1.1.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-twitter/python-twitter-1.0.ebuild,v 1.2 2013/09/05 18:47:04 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="This library provides a pure python interface for the Twitter API"
+HOMEPAGE="https://github.com/bear/python-twitter"
+SRC_URI="https://github.com/bear/python-twitter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="examples test"
+
+RDEPEND="
+ virtual/python-argparse
+ >=dev-python/httplib2-0.7.7
+ >=dev-python/simplejson-3.3.1
+ >=dev-python/requests-1.2.3
+ >=dev-python/requests-oauthlib-0.3.3
+ >=dev-python/oauth2-1.5.211
+ >=dev-python/oauthlib-0.6.0
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+DOCS="CHANGES README.md"
+PYTHON_MODNAME="twitter.py"
+
+src_prepare() {
+ distutils_src_prepare
+ # Delete internal copy of simplejson.
+ rm -fr simplejson
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils_src_install
+
+ dohtml doc/twitter.html
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}