aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild')
-rw-r--r--sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild b/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild
new file mode 100644
index 0000000..fec738f
--- /dev/null
+++ b/sci-chemistry/mopac2007-bin/mopac2007-bin-8.032.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/mopac7/mopac7-1.10-r1.ebuild,v 1.4 2006/12/14 00:27:25 je_fro Exp $
+
+DESCRIPTION="Powerful, fast semi-empirical package"
+HOMEPAGE="http://openmopac.net/"
+SRC_URI="http://openmopac.net/MOPAC_for_Linux_8_032.zip"
+LICENSE="mopac7"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S=${WORKDIR}
+
+pkg_setup() {
+ # We need a license number to proceed
+ if [[ -z ${MOPAC_LICENSE} ]]; then
+ msg="You must set MOPAC_LICENSE to your license number in make.conf."
+ ewarn "$msg"
+ die "$msg"
+ fi
+}
+
+src_install() {
+ into /opt/${PN}
+ newexe MOPAC2007.out ${PN} || die
+ touch "${T}"/${MOPAC_LICENSE} || die
+ doins "${T}"/${MOPAC_LICENSE} || die
+}