aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/scigraphica/files/arrayobject.h.patch')
-rw-r--r--sci-visualization/scigraphica/files/arrayobject.h.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-visualization/scigraphica/files/arrayobject.h.patch b/sci-visualization/scigraphica/files/arrayobject.h.patch
new file mode 100644
index 0000000..6f34c87
--- /dev/null
+++ b/sci-visualization/scigraphica/files/arrayobject.h.patch
@@ -0,0 +1,30 @@
+diff -urN scigraphica-2.1.0.orig/configure scigraphica-2.1.0/configure
+--- scigraphica-2.1.0.orig/configure 2006-04-19 18:44:24.000000000 -0700
++++ scigraphica-2.1.0/configure 2006-04-19 18:45:08.000000000 -0700
+@@ -10544,9 +10544,9 @@
+ PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
+ PY_LIBS="python$PY_VERSION"
+ PY_LIB_LOC="$PY_EXEC_PREFIX/lib/python$PY_VERSION/"
+- array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ if test x$array_loc = x; then
+- array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ fi
+ if test -n $array_loc -a -d $array_loc; then
+ echo "$array_loc"
+diff -urN scigraphica-2.1.0.orig/configure.in scigraphica-2.1.0/configure.in
+--- scigraphica-2.1.0.orig/configure.in 2006-04-19 18:44:24.000000000 -0700
++++ scigraphica-2.1.0/configure.in 2006-04-19 18:44:52.000000000 -0700
+@@ -381,9 +381,9 @@
+ PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
+ PY_LIBS="python$PY_VERSION"
+ PY_LIB_LOC="$PY_EXEC_PREFIX/lib/python$PY_VERSION/"
+- array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ if test x$array_loc = x; then
+- array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ fi
+ if test -n $array_loc -a -d $array_loc; then
+ echo "$array_loc"