aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/scigraphica/Manifest9
-rw-r--r--sci-visualization/scigraphica/files/arrayobject.h.patch30
-rw-r--r--sci-visualization/scigraphica/scigraphica-2.1.0.ebuild28
3 files changed, 43 insertions, 24 deletions
diff --git a/sci-visualization/scigraphica/Manifest b/sci-visualization/scigraphica/Manifest
index dd1759b..e1df490 100644
--- a/sci-visualization/scigraphica/Manifest
+++ b/sci-visualization/scigraphica/Manifest
@@ -1,9 +1,12 @@
+MD5 ffe333045939a9bd868b7e62b2ecde47 files/arrayobject.h.patch 1991
+RMD160 f6043b21772fcb64d12961829075795a32b658c8 files/arrayobject.h.patch 1991
+SHA256 f76faacd88125f723df85f5127617ec90b43b97ad6fb0635a52f51ed610408e6 files/arrayobject.h.patch 1991
MD5 42879ce9fd1eea8caa333d4f5ddab187 files/configure.in.patch 957
RMD160 b5f88fe5338d318746dca5757cb1273d93347391 files/configure.in.patch 957
SHA256 ad522dd278aced1bd4b49d55ed0a0d3562ef45ba1b36f77b6262c0ca413b8c5f files/configure.in.patch 957
MD5 452e979213223b9df25b4d848b5e00a9 files/digest-scigraphica-2.1.0 253
RMD160 32fafc7e2b4676be6f3ce8982a5df100090608d6 files/digest-scigraphica-2.1.0 253
SHA256 5efc6df36c9691309bb0eafe654aea1da67fd25a74162c5bf1f4822f4b1ea482 files/digest-scigraphica-2.1.0 253
-MD5 583e8a3010b1c5617f732f5320903056 scigraphica-2.1.0.ebuild 1649
-RMD160 e779b4cb36e8cac97247952102a9f543132bbb40 scigraphica-2.1.0.ebuild 1649
-SHA256 17d85563e9a10184569127837a1ed424cb0e48413314fcd1457172132cf43853 scigraphica-2.1.0.ebuild 1649
+MD5 be58b8236924dcaa86a12378217ed62b scigraphica-2.1.0.ebuild 1366
+RMD160 ffad01bbeb9076fcdbccf4675804291c7e449f29 scigraphica-2.1.0.ebuild 1366
+SHA256 c26c06f45d4c95acb875edd5ec26020fc0dca937e09396492277426e0a8b23a9 scigraphica-2.1.0.ebuild 1366
diff --git a/sci-visualization/scigraphica/files/arrayobject.h.patch b/sci-visualization/scigraphica/files/arrayobject.h.patch
new file mode 100644
index 0000000..6f34c87
--- /dev/null
+++ b/sci-visualization/scigraphica/files/arrayobject.h.patch
@@ -0,0 +1,30 @@
+diff -urN scigraphica-2.1.0.orig/configure scigraphica-2.1.0/configure
+--- scigraphica-2.1.0.orig/configure 2006-04-19 18:44:24.000000000 -0700
++++ scigraphica-2.1.0/configure 2006-04-19 18:45:08.000000000 -0700
+@@ -10544,9 +10544,9 @@
+ PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
+ PY_LIBS="python$PY_VERSION"
+ PY_LIB_LOC="$PY_EXEC_PREFIX/lib/python$PY_VERSION/"
+- array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ if test x$array_loc = x; then
+- array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ fi
+ if test -n $array_loc -a -d $array_loc; then
+ echo "$array_loc"
+diff -urN scigraphica-2.1.0.orig/configure.in scigraphica-2.1.0/configure.in
+--- scigraphica-2.1.0.orig/configure.in 2006-04-19 18:44:24.000000000 -0700
++++ scigraphica-2.1.0/configure.in 2006-04-19 18:44:52.000000000 -0700
+@@ -381,9 +381,9 @@
+ PY_CFLAGS="-I$PY_PREFIX/include/python$PY_VERSION"
+ PY_LIBS="python$PY_VERSION"
+ PY_LIB_LOC="$PY_EXEC_PREFIX/lib/python$PY_VERSION/"
+- array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $python_numeric_path -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ if test x$array_loc = x; then
+- array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h//`
++ array_loc=`find $PY_PREFIX/ -name arrayobject.h | sed s/arrayobject\.h// | head -n 1`
+ fi
+ if test -n $array_loc -a -d $array_loc; then
+ echo "$array_loc"
diff --git a/sci-visualization/scigraphica/scigraphica-2.1.0.ebuild b/sci-visualization/scigraphica/scigraphica-2.1.0.ebuild
index 82a3292..c576b32 100644
--- a/sci-visualization/scigraphica/scigraphica-2.1.0.ebuild
+++ b/sci-visualization/scigraphica/scigraphica-2.1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-gfx/scigraphica/scigraphica-0.8.0-r2.ebuild,v 1.2 2005/05/09 18:04:34 dholm Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Scientific application for data analysis and technical graphics"
SRC_URI="mirror://sourceforge/scigraphica/${P}.tar.gz"
@@ -26,26 +26,12 @@ DEPEND=">=x11-libs/gtk+extra-2.1.0
src_unpack() {
unpack ${A}
cd ${S}
+ epatch $FILESDIR/arrayobject.h.patch
# Get correct version using scigraphica --version
- epatch $FILESDIR/configure.in.patch
- libtoolize --force || die "libtoolize Failed"
- aclocal || die "aclocal Failed"
- autoconf || die "autoconf Failed"
- autoheader || die "autoheader Failed"
- automake || die "automake Failed"
-}
-
-src_compile() {
- local myconf=""
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "Configuration Failed"
-
- emake || die "Make Failed"
+# epatch $FILESDIR/configure.in.patch
+# einfo "Running intltoolize ..."
+# intltoolize --copy --force
+# eautoreconf
}
src_install() {
@@ -56,7 +42,7 @@ src_install() {
pkg_postinst() {
ewarn "Please be shure to rm your old scigraphica"
- ewarn "configureation directory."
+ ewarn "configuration directory."
ewarn "Otherwise sg won't work."
sleep 5
}