summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2021-03-22 01:03:10 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2021-03-22 01:03:59 +0100
commit0bce642c9e01024c346fc9928fe66639be12ccd4 (patch)
treec121b1c110230b1fcb8c0f6974c285704580fe18
parentapp-emulation/cloud-init: moved to gentoo repository (diff)
downloadeva-0bce642c9e01024c346fc9928fe66639be12ccd4.tar.gz
eva-0bce642c9e01024c346fc9928fe66639be12ccd4.tar.bz2
eva-0bce642c9e01024c346fc9928fe66639be12ccd4.zip
dev-python/rfc6555: initial ebuild
Dependency of offlineimap3. Package-Manager: Portage-3.0.17, Repoman-3.0.2 Manifest-Sign-Key: 0x5A56C8CD0C13248A Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
-rw-r--r--dev-python/rfc6555/metadata.xml15
-rw-r--r--dev-python/rfc6555/rfc6555-1.0.0_pre20190913.ebuild22
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/rfc6555/metadata.xml b/dev-python/rfc6555/metadata.xml
new file mode 100644
index 0000000..23e7bf8
--- /dev/null
+++ b/dev-python/rfc6555/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">rfc6555</remote-id>
+ <remote-id type="github">sethmlarson/rfc6555</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rfc6555/rfc6555-1.0.0_pre20190913.ebuild b/dev-python/rfc6555/rfc6555-1.0.0_pre20190913.ebuild
new file mode 100644
index 0000000..a09ae45
--- /dev/null
+++ b/dev-python/rfc6555/rfc6555-1.0.0_pre20190913.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Implementation of the Happy Eyeballs Algorithm described in RFC 6555."
+HOMEPAGE="https://github.com/sethmlarson/rfc6555"
+EGIT_REPO_URI="https://github.com/sethmlarson/${PN}.git"
+EGIT_COMMIT="1a181b432312731f6742a5eb558dae4761d32361"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BDEPEND="${BDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest