summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-23 14:52:00 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-23 14:52:00 +0200
commit8de38b68f42c6ee80193e1503f5e457c3a6a855e (patch)
treebefbc99a7f061c094154dbf6c84c61a1a2cb556f /dev-python/rq-dashboard
parentdev-python/rq: does not work with python3 (diff)
downloadeva-8de38b68f42c6ee80193e1503f5e457c3a6a855e.tar.gz
eva-8de38b68f42c6ee80193e1503f5e457c3a6a855e.tar.bz2
eva-8de38b68f42c6ee80193e1503f5e457c3a6a855e.zip
dev-python/rq-dashboard: initial ebuild
Diffstat (limited to 'dev-python/rq-dashboard')
-rw-r--r--dev-python/rq-dashboard/Manifest11
-rw-r--r--dev-python/rq-dashboard/metadata.xml8
-rw-r--r--dev-python/rq-dashboard/rq-dashboard-0.3.ebuild28
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/rq-dashboard/Manifest b/dev-python/rq-dashboard/Manifest
new file mode 100644
index 0000000..7c25cf6
--- /dev/null
+++ b/dev-python/rq-dashboard/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+DIST rq-dashboard-0.3.tar.gz 85513 SHA256 9920db98da93086ec433f589f0e5c0c1bcdbd50b8535de6534c81e67921785ad SHA512 24544902eb0f99c2e595c8c1d09788e1fe3b9a410613e820ba2f41deabd4d3716504e91d2c0f1f8f12367fa57a71d481c76c112aca0d39517fbc7f16d1750217 WHIRLPOOL 52a76ea60003f5a022c2b4ed4bcaa54c49a8cd0cd5c26343662144cea3401265bf483f8449f498e2e0650310486a9aae1d3d12d15f65a75f7306c40f1fe14e31
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEAREKAAYFAlCGkvAACgkQ1fmVwcYIWAbr1gCgjylN6Pxq8cXUWeidXPBmjK2b
+cnwAoK5KTzpizI1hhYVKft+fegQI9jGf
+=PIEZ
+-----END PGP SIGNATURE-----
diff --git a/dev-python/rq-dashboard/metadata.xml b/dev-python/rq-dashboard/metadata.xml
new file mode 100644
index 0000000..23310c6
--- /dev/null
+++ b/dev-python/rq-dashboard/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/rq-dashboard/rq-dashboard-0.3.ebuild b/dev-python/rq-dashboard/rq-dashboard-0.3.ebuild
new file mode 100644
index 0000000..891e64f
--- /dev/null
+++ b/dev-python/rq-dashboard/rq-dashboard-0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/rsa-3.1.1.ebuild,v 1.4 2012/08/19 18:48:44 johu Exp $
+
+EAPI="4"
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Web interface to monitor your RQ queues, jobs, and workers in realtime"
+HOMEPAGE="https://github.com/nvie/rq-dashboard"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/flask
+ dev-python/redis-py
+ dev-python/rq
+ dev-python/simplejson
+ dev-python/times
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"