summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-07-27 20:49:18 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2015-07-27 21:07:41 +0200
commit30491332e11db77fc1d8c3e667e21e00c4d25b33 (patch)
tree640769069a0e6ee936c94abaaa52d235fbe9d363 /dev-python/rq
parentdev-python/times: 0.6 → 0.7 (diff)
downloadeva-30491332e11db77fc1d8c3e667e21e00c4d25b33.tar.gz
eva-30491332e11db77fc1d8c3e667e21e00c4d25b33.tar.bz2
eva-30491332e11db77fc1d8c3e667e21e00c4d25b33.zip
dev-python/rq: 0.3.7 → 0.5.4
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest12
-rw-r--r--dev-python/rq/rq-0.3.7.ebuild36
-rw-r--r--dev-python/rq/rq-0.5.4.ebuild26
3 files changed, 27 insertions, 47 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 20fc30a..c59ee72 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,11 +1 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA512
-
-DIST rq-0.3.7.tar.gz 38645 SHA256 368bfd9c3a4443239d3b357cc9685abc09bedc22b5436256c3d9f9ef7d156a3b SHA512 e3983d91861704be65977885054d2827aaedb549cfccc567cb8116cc881e505243c37c0b5432ab19621a246e644570ba6a75cbfa2c448b942c70de01845ce1c6 WHIRLPOOL 41f75ff20430661adc1b7b63669ffffadb9350bba7edf4319f725645d4a90c9eb1d25f4f04e6d3c451c20789f279c2747527a3804be57de8816fa19f9eb0a1dc
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.19 (GNU/Linux)
-
-iEYEAREKAAYFAlExLF4ACgkQ1fmVwcYIWAZcgwCgwe+Le6EN5HXcMGiA/MTMkPDO
-JHAAoJ2rxVDRgODN3HL4ynEvdlcew8AH
-=C0lf
------END PGP SIGNATURE-----
+DIST rq-0.5.4.tar.gz 45771 SHA256 fb1e4b43304968e4cdd8f3bfecf3cd4ec69b79a1bdb35dd0f259a42f4ad78099 SHA512 2e069351ed11a6a3130cd9a5152f393ff92e04e14e94a856b2a03cf165e04cdb2e8642842ab938235ed192a51a6d27b795c4c0461ecc534a88590a571034318c WHIRLPOOL c48738aac51ef9dd49081aaa1126044335781a4ac9826b13ee3a1ac378c4f375c8544e357a9568a0c4cda49e074a6ea30c3ca60f6db1707ceca8810f514b88a9
diff --git a/dev-python/rq/rq-0.3.7.ebuild b/dev-python/rq/rq-0.3.7.ebuild
deleted file mode 100644
index 334b801..0000000
--- a/dev-python/rq/rq-0.3.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_{5,6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="RQ is a simple, lightweight, library for creating background jobs, and processing them"
-HOMEPAGE="http://python-rq.org"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- >=dev-db/redis-2.4.13
- dev-python/redis-py[${PYTHON_USEDEP}]
- dev-python/times[${PYTHON_USEDEP}]
- virtual/python-argparse[${PYTHON_USEDEP}]
- python_targets_python2_5? ( dev-python/importlib )
- python_targets_python2_6? ( dev-python/importlib )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools
-"
-
-python_prepare_all() {
- # No unittest since it requires a running redis
- # installation of tests is done in site-packages directly which is not
- # optimal.
- rm -r tests || die
-}
diff --git a/dev-python/rq/rq-0.5.4.ebuild b/dev-python/rq/rq-0.5.4.ebuild
new file mode 100644
index 0000000..fc6fda0
--- /dev/null
+++ b/dev-python/rq/rq-0.5.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="RQ is a simple, lightweight, library for creating background jobs, and processing them"
+HOMEPAGE="http://python-rq.org"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-db/redis-2.7
+ >=dev-python/redis-py-2.7[${PYTHON_USEDEP}]
+ >=dev-python/click-3[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"