summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-20 13:38:51 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-20 13:38:51 +0200
commit7c662e0cc7b2ff790c0714eb3c116db9440f7239 (patch)
tree84566b6c3bdd8a28ee1d9a147384dff72f0a4eb7 /dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
parentdev-python/times: fix dependencies (diff)
downloadeva-7c662e0cc7b2ff790c0714eb3c116db9440f7239.tar.gz
eva-7c662e0cc7b2ff790c0714eb3c116db9440f7239.tar.bz2
eva-7c662e0cc7b2ff790c0714eb3c116db9440f7239.zip
dev-python/webarticle2text: fix missing encoding
* Fix license. * Add missing metadata.
Diffstat (limited to 'dev-python/webarticle2text/webarticle2text-1.2.4.ebuild')
-rw-r--r--dev-python/webarticle2text/webarticle2text-1.2.4.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild b/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
index 0c686d0..5b820fe 100644
--- a/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
+++ b/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
@@ -6,13 +6,13 @@ EAPI="4"
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-inherit distutils-r1
+inherit distutils-r1 eutils
DESCRIPTION="Extracts the main article text from a webpage"
HOMEPAGE="https://github.com/chrisspen/webarticle2text"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-LICENSE="LGPL"
+LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -27,3 +27,10 @@ DEPEND="${RDEPEND}
# Not distributed yet
#DOCS=( README.rst )
+
+src_prepare() {
+ # Add missing coding as required by pep267
+ epatch "${FILESDIR}/${P}-encoding.patch"
+
+ distutils-r1_src_prepare
+}