summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-20 11:48:09 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-20 11:48:09 +0200
commitbe1800a12fb1e0a538b7766c52233b172eb9e048 (patch)
tree1bea72a16e53ab0dc5cc64b51f8cbcef6dec66df /dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
parentdev-python/pytidylib: initial ebuild (diff)
downloadeva-be1800a12fb1e0a538b7766c52233b172eb9e048.tar.gz
eva-be1800a12fb1e0a538b7766c52233b172eb9e048.tar.bz2
eva-be1800a12fb1e0a538b7766c52233b172eb9e048.zip
dev-python/webarticle2text: initial ebuild
Diffstat (limited to 'dev-python/webarticle2text/webarticle2text-1.2.4.ebuild')
-rw-r--r--dev-python/webarticle2text/webarticle2text-1.2.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild b/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
new file mode 100644
index 0000000..0c686d0
--- /dev/null
+++ b/dev-python/webarticle2text/webarticle2text-1.2.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/rsa-3.1.1.ebuild,v 1.4 2012/08/19 18:48:44 johu Exp $
+
+EAPI="4"
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Extracts the main article text from a webpage"
+HOMEPAGE="https://github.com/chrisspen/webarticle2text"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/chardet
+ dev-python/pytidylib
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+"
+
+# Not distributed yet
+#DOCS=( README.rst )