summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rq/rq-0.3.2.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/rq/rq-0.3.2.ebuild b/dev-python/rq/rq-0.3.2.ebuild
index 7d8580f..8e2f8ee 100644
--- a/dev-python/rq/rq-0.3.2.ebuild
+++ b/dev-python/rq/rq-0.3.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/rsa/rsa-3.1.1.ebuild,v 1.4 2012/08/19 18:48:44 johu Exp $
+# $Header: $
EAPI="4"
-PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+PYTHON_COMPAT=( python2_{5,6,7} )
inherit distutils-r1
@@ -21,12 +21,9 @@ RDEPEND="
dev-python/logbook
dev-python/redis-py
dev-python/times
- python_targets_python2_5? (
- dev-python/argparse
- dev-python/importlib )
- python_targets_python2_6? (
- dev-python/argparse
- dev-python/importlib )
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ python_targets_python2_5? ( dev-python/importlib )
+ python_targets_python2_6? ( dev-python/importlib )
"
DEPEND="${RDEPEND}
dev-python/setuptools