summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-strategy/freeciv/freeciv-9999.ebuild34
-rw-r--r--sys-fs/fuseiso/fuseiso-20070708.ebuild21
2 files changed, 44 insertions, 11 deletions
diff --git a/games-strategy/freeciv/freeciv-9999.ebuild b/games-strategy/freeciv/freeciv-9999.ebuild
index 8bccc10..be7fa5d 100644
--- a/games-strategy/freeciv/freeciv-9999.ebuild
+++ b/games-strategy/freeciv/freeciv-9999.ebuild
@@ -6,9 +6,11 @@ inherit eutils games subversion flag-o-matic
ESVN_REPO_URI="http://svn.gna.org/svn/freeciv/trunk"
+MY_P=${PN}-${PV/_/-}
DESCRIPTION="multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
-SRC_URI="mirror://gentoo/${PN}.png
+SRC_URI="
+ mirror://gentoo/${PN}.png
!dedicated? (
alsa? (
ftp://ftp.freeciv.org/freeciv/contrib/audio/soundsets/stdsounds3.tar.gz )
@@ -29,10 +31,16 @@ RDEPEND="readline? ( sys-libs/readline )
gtk? ( >=x11-libs/gtk+-2 )
!gtk? (
Xaw3d? ( x11-libs/Xaw3d )
- !Xaw3d? ( x11-libs/libXaw )
- x11-libs/libXmu
- x11-libs/libXpm
+ !Xaw3d? (
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/freetype
+ )
+ !sdl? ( x11-libs/libXaw )
+ )
)
+ media-libs/libpng
alsa? (
media-libs/alsa-lib
media-libs/audiofile
@@ -43,9 +51,12 @@ RDEPEND="readline? ( sys-libs/readline )
)"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
- !dedicated? ( gtk? ( dev-util/pkgconfig ) )
- x11-proto/xextproto
- media-libs/libpng"
+ !dedicated? (
+ gtk? ( dev-util/pkgconfig )
+ x11-proto/xextproto
+ )"
+
+S=${WORKDIR}/${MY_P}
pkg_setup() {
games_pkg_setup
@@ -54,6 +65,8 @@ pkg_setup() {
elog "The Freeciv Client will be built with the GTK+-2 toolkit"
elif use Xaw3d ; then
elog "The Freeciv Client will be built with the Xaw3d toolkit"
+ elif use sdl ; then
+ elog "The Freeciv Client will be built with the SDL toolkit"
else
elog "The Freeciv Client will be built with the Xaw toolkit"
fi
@@ -116,6 +129,7 @@ src_compile() {
myclient="no"
else
myclient="xaw"
+ use sdl && myclient="sdl"
use Xaw3d && myclient="xaw3d"
if use gtk ; then
myclient="gtk-2.0"
@@ -134,7 +148,6 @@ src_compile() {
$(use_enable nls) \
$(use_with readline) \
--enable-client=${myclient} \
- --disable-nls \
${mysoundconf} \
|| die "egamesconf failed"
@@ -146,7 +159,7 @@ src_install() {
if ! use dedicated ; then
# Install the app-defaults if Xaw/Xaw3d toolkit
- if ! use gtk ; then
+ if ! use gtk && ! use sdl ; then
insinto /etc/X11/app-defaults
doins data/Freeciv || die "doins failed"
fi
@@ -165,8 +178,7 @@ src_install() {
rm -f "${D}/${GAMES_BINDIR}"/civmanual
fi
- dodoc ChangeLog NEWS \
- doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,PEOPLE,README*,TODO}
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
doicon "${DISTDIR}"/${PN}.png
prepgamesdirs
diff --git a/sys-fs/fuseiso/fuseiso-20070708.ebuild b/sys-fs/fuseiso/fuseiso-20070708.ebuild
new file mode 100644
index 0000000..d6afa07
--- /dev/null
+++ b/sys-fs/fuseiso/fuseiso-20070708.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="FuseIso is a FUSE module to mount ISO filesystem images (.iso
+files, .bin files, .nrg files..)."
+HOMEPAGE="http://fuse.sourceforge.net/wiki/index.php/FuseIso"
+SRC_URI="http://ubiz.ru/dm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=" >=sys-fs/fuse-2.3
+ >=dev-libs/glib-2.4.2
+"
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO ChangeLog
+}