summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2022-08-05 10:52:40 +0200
committerHans de Graaff <hans@degraaff.org>2022-08-05 10:52:40 +0200
commit4c47ab3688fcaf2a09195196afe80cd7c8cc312f (patch)
tree9f4dc3e2104ada91a537894e6fd4a36f09a5ca13
parentdev-ruby/feed_parser: enable ruby31 (diff)
downloadgraaff-4c47ab3688fcaf2a09195196afe80cd7c8cc312f.tar.gz
graaff-4c47ab3688fcaf2a09195196afe80cd7c8cc312f.tar.bz2
graaff-4c47ab3688fcaf2a09195196afe80cd7c8cc312f.zip
dev-ruby/pipedrive-rb: enable ruby30
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/pipedrive-rb/pipedrive-rb-0.3.0-r1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ruby/pipedrive-rb/pipedrive-rb-0.3.0-r1.ebuild b/dev-ruby/pipedrive-rb/pipedrive-rb-0.3.0-r1.ebuild
index 6b485c09..ef0bbd3a 100644
--- a/dev-ruby/pipedrive-rb/pipedrive-rb-0.3.0-r1.ebuild
+++ b/dev-ruby/pipedrive-rb/pipedrive-rb-0.3.0-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby26 ruby27"
+USE_RUBY="ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -34,4 +34,8 @@ ruby_add_bdepend "test? ( dev-ruby/webmock )"
all_ruby_prepare() {
sed -i -e '/simplecov/,/^end/ s:^:#:' spec/spec_helper.rb || die
sed -i -e 's/v0.2.0/v0.3.0/' spec/lib/pipedrive/base_spec.rb || die
+
+ sed -i -e '1igem "faraday", "<2"' spec/spec_helper.rb || die
+
+ sed -i -e '/with/ s/start: 0/{ start: 0 }/ ; /with/ s/start: 10/{ start: 10 }/' spec/lib/pipedrive/operations/read_spec.rb || die
}