summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2023-09-19 07:34:26 +0200
committerHans de Graaff <hans@degraaff.org>2023-09-19 07:34:26 +0200
commite65f3edfc2d52428b9435ec6f58f35fad628551a (patch)
tree3e3614dc3a1631a0ed1c6f8c7507281e4404d72b
parentdev-ruby/rubocop-performance: add 1.19.1 (diff)
downloadgraaff-e65f3edfc2d52428b9435ec6f58f35fad628551a.tar.gz
graaff-e65f3edfc2d52428b9435ec6f58f35fad628551a.tar.bz2
graaff-e65f3edfc2d52428b9435ec6f58f35fad628551a.zip
dev-ruby/rubocop-factory_bot: add 2.24.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
-rw-r--r--dev-ruby/rubocop-factory_bot/Manifest1
-rw-r--r--dev-ruby/rubocop-factory_bot/rubocop-factory_bot-2.24.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-factory_bot/Manifest b/dev-ruby/rubocop-factory_bot/Manifest
index ca12ef06..036e4a20 100644
--- a/dev-ruby/rubocop-factory_bot/Manifest
+++ b/dev-ruby/rubocop-factory_bot/Manifest
@@ -1 +1,2 @@
DIST rubocop-factory_bot-2.23.1.tar.gz 32554 BLAKE2B bbee4d84424b94772a2562e19a734f516c08c1a132b87cc069e8f6428e122b29c7ea484064b61221a4aa9eebae1f8b8c01051fd42341d1b18e13a51b0f9e21f6 SHA512 8d30a0b052a164e86bbeefc08a4c29169e7fa39527c94975acc4c85c8e3efa1f57f05aff75c2124fa500a91f5855573e47b7b400c5c70e1c6480d58cdf8fbc20
+DIST rubocop-factory_bot-2.24.0.tar.gz 34668 BLAKE2B 4e5bf7e827067851939eea3f789cb5dc672af25be1112a75e126bd43156d36bb8ace442915e87d97ea90daa101686d45114149a0952b9de2efb5b3020cfcf2b4 SHA512 23fa4e845c8a62616ca3580a06894abc0055ae20b77423760b535ba6d9313f1f9dbd440633e257d21fed484e59a5531d73852cea55744fc65e9ad708a5dc5e6b
diff --git a/dev-ruby/rubocop-factory_bot/rubocop-factory_bot-2.24.0.ebuild b/dev-ruby/rubocop-factory_bot/rubocop-factory_bot-2.24.0.ebuild
new file mode 100644
index 00000000..ba33ac79
--- /dev/null
+++ b/dev-ruby/rubocop-factory_bot/rubocop-factory_bot-2.24.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-factory_bot.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Code style checking for RSpec files"
+HOMEPAGE="https://github.com/rubocop/rubocop-factory_bot"
+SRC_URI="https://github.com/rubocop/rubocop-factory_bot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rubocop-1* >=dev-ruby/rubocop-1.33
+"