summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-09-17 07:20:50 +0200
committerHans de Graaff <hans@degraaff.org>2024-09-17 07:20:50 +0200
commit2c3854df3d9e3db9283c637459ec89cb7f0892b1 (patch)
tree7f4bd02ad0f27d57dd163e27b007f44789bb11fc /dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild
parentdev-ruby/solargraph: drop 0.49.0 (diff)
downloadgraaff-2c3854df3d9e3db9283c637459ec89cb7f0892b1.tar.gz
graaff-2c3854df3d9e3db9283c637459ec89cb7f0892b1.tar.bz2
graaff-2c3854df3d9e3db9283c637459ec89cb7f0892b1.zip
dev-ruby/rubocop-performance: add 1.22.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild')
-rw-r--r--dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild b/dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild
new file mode 100644
index 00000000..ec2a15b7
--- /dev/null
+++ b/dev-ruby/rubocop-performance/rubocop-performance-1.22.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="config"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop-performance.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A collection of RuboCop cops to check for performance optimizations in Ruby code"
+HOMEPAGE="https://github.com/rubocop/rubocop-performance/"
+SRC_URI="https://github.com/rubocop/rubocop-performance/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/rubocop-1.48.1:0
+ >=dev-ruby/rubocop-ast-1.31.1
+"