summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2023-04-20 07:38:08 +0200
committerHans de Graaff <hans@degraaff.org>2023-04-20 07:38:08 +0200
commit4ab7d752064fe6bda5dc2bcceb27413f4568cce6 (patch)
tree79167901bc91f62beb8b9c2242c5574b7eabd47b /dev-ruby/rubocop/rubocop-1.46.0.ebuild
parentdev-ruby/rubocop: add 1.50.2 (diff)
downloadgraaff-4ab7d752064fe6bda5dc2bcceb27413f4568cce6.tar.gz
graaff-4ab7d752064fe6bda5dc2bcceb27413f4568cce6.tar.bz2
graaff-4ab7d752064fe6bda5dc2bcceb27413f4568cce6.zip
dev-ruby/rubocop: drop 1.46.0, 1.48.0, 1.50.0
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/rubocop/rubocop-1.46.0.ebuild')
-rw-r--r--dev-ruby/rubocop/rubocop-1.46.0.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ruby/rubocop/rubocop-1.46.0.ebuild b/dev-ruby/rubocop/rubocop-1.46.0.ebuild
deleted file mode 100644
index 22749755..00000000
--- a/dev-ruby/rubocop/rubocop-1.46.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets config"
-RUBY_FAKEGEM_BINDIR="exe"
-
-RUBY_FAKEGEM_GEMSPEC="rubocop.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby static code analyzer"
-HOMEPAGE="https://github.com/rubocop/rubocop"
-SRC_URI="https://github.com/rubocop/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/json-2.3:2
- >=dev-ruby/parallel-1.10:1
- >=dev-ruby/parser-3.2.0.0
- dev-ruby/rainbow:3
- dev-ruby/regexp_parser:2
- >=dev-ruby/rexml-3.2.5:3
- >=dev-ruby/rubocop-ast-1.26.0:1
- >=dev-ruby/ruby-progressbar-1.7:0
- >=dev-ruby/unicode-display_width-2.4.0:2"
-
-ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rubocop-performance dev-ruby/webmock )"
-
-all_ruby_prepare() {
- sed -e '/pry/ s:^:#:' \
- -i spec/spec_helper.rb || die
- sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid bundler spec
- sed -i -e '/and the gem is bundled/,/^ end/ s:^:#:' spec/rubocop/config_loader_spec.rb || die
- sed -i -e '/bundler integration/,/^ end/ s:^:#:' spec/rubocop/cli_spec.rb || die
- rm -f spec/rubocop/cli_spec.rb spec/rubocop/cli/suggest_extensions_spec.rb spec/rubocop/lockfile_spec.rb || die
-
- # Avoid specs requiring rubocop-rake
- sed -i -e '/compliance with rubocop/,/^ end/ s:^:#:' spec/rubocop/cop/generator_spec.rb || die
-
- # Avoid specs requiring many rubocop extensions
- rm -f spec/rubocop/version_spec.rb || die
-
- # Avoid specs that are not functional and break too often in releases
- sed -i -e '/has a unique contributor name/askip "too fragile"' spec/project_spec.rb || die
-
- sed -e 's:/tmp/example:'${TMPDIR}'/example:' \
- -e 's:/tmp/Gemfile:'${TMPDIR}'/Gemfile:' \
- -i spec/rubocop/cop/team_spec.rb || die
- sed -e 's:/tmp:'${TMPDIR}':' -i spec/rubocop/server/cli_spec.rb || die
-}