summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rubocop')
-rw-r--r--dev-ruby/rubocop/Manifest1
-rw-r--r--dev-ruby/rubocop/rubocop-1.50.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rubocop/Manifest b/dev-ruby/rubocop/Manifest
index 0b8f12d9..8e858faa 100644
--- a/dev-ruby/rubocop/Manifest
+++ b/dev-ruby/rubocop/Manifest
@@ -5,3 +5,4 @@ DIST rubocop-1.48.1.tar.gz 2277655 BLAKE2B de203542c64b342f56834da68f001bb20f140
DIST rubocop-1.49.0.tar.gz 2285329 BLAKE2B 006c3dc07c503af67538c501c3782eedc65cb1075a44c83b81a65495218fa64b86f5817ffba5f16801de74bf0483158e536d477f3c6ab1310f24c6f1ef870291 SHA512 6c9c6a1dc27013386378631a50d1b662f2a3ace64914ca44e320ab5ed410e65de088dea31ee3b49997d1074a6cb35c44481a67aee8b957507f9c00054b384571
DIST rubocop-1.50.0.tar.gz 2287251 BLAKE2B fb32d3b6574c60bef1642cc88390a4336f654ea01c1e2c2c5b85352d587dc89dc6b0ed7a04a4098f414fd339dd03b0249cfdaa6bad86d3dfec463c31ac3080e3 SHA512 c48bf76c2cbcb5d95284a5fda1ba30f4b4d5cd6c6a6b67f8e25c013a4f94e14fc19dcf899ae41838cac372e660d3e34fc27c43a43239bdf12bd58c77e2ec8562
DIST rubocop-1.50.1.tar.gz 2289625 BLAKE2B f5b3ec5453de9e1c3ec5bc2f7b03821acbc0a404a27b420f025f2649abed29a54925b93a66431850fb9c47a3ff857a781776c474484ce17d2018896ff2057885 SHA512 56f9184f3d694b2c9979e7fbc4c992a0f691d99a9c29e0c73a9d974645abe395d3a365b8d2ea227104b44c82746cfd0b6036b3db86dcf179a42fb2d7dc662830
+DIST rubocop-1.50.2.tar.gz 2290318 BLAKE2B 346289266b5854890de8deb58d1ca933e7852246acf76dcc12e892425a31bbff07b7046ad14510f8815abaa813720b46d42dbe41596defd6e5de1a3e99c0ebb5 SHA512 d075dc567d486ef38116034b56641c072ab0aba719ed7575a1aaeef5324049225b6de13b71dd5fb6885e3c2ca0709cae76a26ee8259ccf2c7ea19c9256648333
diff --git a/dev-ruby/rubocop/rubocop-1.50.2.ebuild b/dev-ruby/rubocop/rubocop-1.50.2.ebuild
new file mode 100644
index 00000000..7e30be2e
--- /dev/null
+++ b/dev-ruby/rubocop/rubocop-1.50.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets config"
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rubocop.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby static code analyzer"
+HOMEPAGE="https://github.com/rubocop/rubocop"
+SRC_URI="https://github.com/rubocop/rubocop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/json-2.3:2
+ >=dev-ruby/parallel-1.10:1
+ >=dev-ruby/parser-3.2.0.0
+ dev-ruby/rainbow:3
+ dev-ruby/regexp_parser:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubocop-ast-1.28.0:1
+ >=dev-ruby/ruby-progressbar-1.7:0
+ >=dev-ruby/unicode-display_width-2.4.0:2"
+
+ruby_add_bdepend "test? ( dev-ruby/bundler dev-ruby/rubocop-performance dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -e '/pry/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid bundler spec
+ sed -i -e '/and the gem is bundled/,/^ end/ s:^:#:' spec/rubocop/config_loader_spec.rb || die
+ sed -i -e '/bundler integration/,/^ end/ s:^:#:' spec/rubocop/cli_spec.rb || die
+ rm -f spec/rubocop/cli_spec.rb spec/rubocop/cli/suggest_extensions_spec.rb spec/rubocop/lockfile_spec.rb || die
+
+ # Avoid specs requiring rubocop-rake
+ sed -i -e '/compliance with rubocop/,/^ end/ s:^:#:' spec/rubocop/cop/generator_spec.rb || die
+
+ # Avoid specs requiring many rubocop extensions
+ rm -f spec/rubocop/version_spec.rb || die
+
+ # Avoid specs that are not functional and break too often in releases
+ sed -i -e '/has a unique contributor name/askip "too fragile"' spec/project_spec.rb || die
+
+ sed -e 's:/tmp/example:'"${TMPDIR}"'/example:' \
+ -e 's:/tmp/Gemfile:'"${TMPDIR}"'/Gemfile:' \
+ -i spec/rubocop/cop/team_spec.rb || die
+ sed -e 's:/tmp:'"${TMPDIR}"':' -i spec/rubocop/server/cli_spec.rb || die
+}