summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2007-05-12 15:12:39 +0000
committerAkinori Hattori <hattya@gentoo.org>2007-05-12 15:12:39 +0000
commitf829e5dd46bdee5480a6c347e79496ab18cff28b (patch)
treebcab3d83a45d5881e1c3e539583329a98145529e
parentupdate subversion.eclass. (diff)
downloadhattya-f829e5dd46bdee5480a6c347e79496ab18cff28b.tar.gz
hattya-f829e5dd46bdee5480a6c347e79496ab18cff28b.tar.bz2
hattya-f829e5dd46bdee5480a6c347e79496ab18cff28b.zip
replace DEFAULT_BROWSER_CMD to firefox.
svn path=/; revision=11
-rw-r--r--mail-client/sylpheed-svn/files/sylpheed-2.4-firefox.diff12
-rw-r--r--mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild38
2 files changed, 29 insertions, 21 deletions
diff --git a/mail-client/sylpheed-svn/files/sylpheed-2.4-firefox.diff b/mail-client/sylpheed-svn/files/sylpheed-2.4-firefox.diff
new file mode 100644
index 0000000..79ee315
--- /dev/null
+++ b/mail-client/sylpheed-svn/files/sylpheed-2.4-firefox.diff
@@ -0,0 +1,12 @@
+diff -Naur sylpheed-2.4.1.orig/libsylph/defs.h sylpheed-2.4.1/libsylph/defs.h
+--- sylpheed-2.4.1.orig/libsylph/defs.h 2006-09-22 11:58:56.000000000 +0900
++++ sylpheed-2.4.1/libsylph/defs.h 2007-05-07 17:25:18.000000000 +0900
+@@ -92,7 +92,7 @@
+ /* #define DEFAULT_INC_PATH "/usr/bin/imget" */
+ /* #define DEFAULT_INC_PROGRAM "imget" */
+ #define DEFAULT_SENDMAIL_CMD "/usr/sbin/sendmail -t -i"
+-#define DEFAULT_BROWSER_CMD "mozilla-firefox -remote 'openURL(%s,new-window)'"
++#define DEFAULT_BROWSER_CMD "firefox -remote 'openURL(%s,new-window)'"
+
+ #ifdef _PATH_MAILDIR
+ # define DEFAULT_SPOOL_PATH _PATH_MAILDIR
diff --git a/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild b/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
index fa22b80..9d5e1ec 100644
--- a/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
+++ b/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -14,13 +14,10 @@ DESCRIPTION="A lightweight email client and newsreader"
HOMEPAGE="http://sylpheed.sraoss.jp/"
SRC_URI=""
-RESTRICT="nomirror"
-LICENSE="GPL-2"
+LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="~ia64 ~x86"
SLOT="0"
-PROVIDE="virtual/sylpheed"
-
DEPEND=">=x11-libs/gtk+-2.4
nls? ( >=sys-devel/gettext-0.12.1 )
crypt? ( >=app-crypt/gpgme-0.4.5 )
@@ -36,15 +33,19 @@ RDEPEND="${DEPEND}
src_compile() {
+ local htmldir=/usr/share/doc/${PF}/html
+
econf \
- `use_enable crypt gpgme` \
- `use_enable ipv6` \
- `use_enable ldap` \
- `use_enable nls` \
- `use_enable pda jpilot` \
- `use_enable spell gtkspell` \
- `use_enable ssl` \
- `use_enable xface compface` \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
|| die
emake || die
@@ -52,16 +53,11 @@ src_compile() {
src_install() {
- emake DESTDIR="${D}" install
-
- dodir /usr/share/pixmaps
- insinto /usr/share/pixmaps
- doins *.png
-
- insinto /usr/share/applications
- doins sylpheed.desktop
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
}