summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild')
-rw-r--r--mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild38
1 files changed, 17 insertions, 21 deletions
diff --git a/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild b/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
index fa22b80..9d5e1ec 100644
--- a/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
+++ b/mail-client/sylpheed-svn/sylpheed-svn-2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -14,13 +14,10 @@ DESCRIPTION="A lightweight email client and newsreader"
HOMEPAGE="http://sylpheed.sraoss.jp/"
SRC_URI=""
-RESTRICT="nomirror"
-LICENSE="GPL-2"
+LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="~ia64 ~x86"
SLOT="0"
-PROVIDE="virtual/sylpheed"
-
DEPEND=">=x11-libs/gtk+-2.4
nls? ( >=sys-devel/gettext-0.12.1 )
crypt? ( >=app-crypt/gpgme-0.4.5 )
@@ -36,15 +33,19 @@ RDEPEND="${DEPEND}
src_compile() {
+ local htmldir=/usr/share/doc/${PF}/html
+
econf \
- `use_enable crypt gpgme` \
- `use_enable ipv6` \
- `use_enable ldap` \
- `use_enable nls` \
- `use_enable pda jpilot` \
- `use_enable spell gtkspell` \
- `use_enable ssl` \
- `use_enable xface compface` \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable nls) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
|| die
emake || die
@@ -52,16 +53,11 @@ src_compile() {
src_install() {
- emake DESTDIR="${D}" install
-
- dodir /usr/share/pixmaps
- insinto /usr/share/pixmaps
- doins *.png
-
- insinto /usr/share/applications
- doins sylpheed.desktop
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+ doicon *.png
+ domenu *.desktop
}