summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-09-17 03:37:03 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-09-17 03:37:03 +0000
commit9e98316eabb09cc162f110535398cb019b8850f0 (patch)
treee925a04ee1b9fd48c5d81000207a97ab6228aa98 /sci-biology/meme/meme-3.5.4.ebuild
parentFixing up meme for amd64. (diff)
downloadje_fro-9e98316eabb09cc162f110535398cb019b8850f0.tar.gz
je_fro-9e98316eabb09cc162f110535398cb019b8850f0.tar.bz2
je_fro-9e98316eabb09cc162f110535398cb019b8850f0.zip
Added to main tree.
svn path=/; revision=76
Diffstat (limited to 'sci-biology/meme/meme-3.5.4.ebuild')
-rw-r--r--sci-biology/meme/meme-3.5.4.ebuild88
1 files changed, 0 insertions, 88 deletions
diff --git a/sci-biology/meme/meme-3.5.4.ebuild b/sci-biology/meme/meme-3.5.4.ebuild
deleted file mode 100644
index d05d8c5..0000000
--- a/sci-biology/meme/meme-3.5.4.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/meme/meme-3.5.4.ebuild,v 1.1 2007/04/24 20:44:01 ribosome Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="The MEME/MAST system - Motif discovery and search"
-HOMEPAGE="http://meme.sdsc.edu/meme"
-SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
-LICENSE="meme"
-
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-# Other possible USE flags include "debug", "client", "server", "web",
-# "queue". Other variables must be set at compile time, but only when
-# the Web server is built. Right now, Web server and client are disabled.
-IUSE="mpi"
-
-# Works only with LAM-MPI.
-DEPEND=">=dev-lang/perl-5.6.1
- mpi? ( sys-cluster/lam-mpi )"
-
-S="${WORKDIR}/${PN}_${PV}"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}/${P}-Makefile.am.patch"
- einfo "Regenerating autotools files..."
- eautoreconf
-}
-
-src_compile() {
- local EXTRA_CONF
- # Build system is too bugy to make the programs use standard locations.
- # Put everything in "/opt" instead.
- EXTRA_CONF="${EXTRA_CONF} --prefix=/opt/${PN}"
- EXTRA_CONF="${EXTRA_CONF} --with-logs=/var/log/${PN}"
- # Connect hyperlinks to official Web site.
- EXTRA_CONF="${EXTRA_CONF} --with-url=http://meme.nbcr.net/meme"
- # Disable Web server, client and Web site.
- EXTRA_CONF="${EXTRA_CONF} --disable-server --disable-client --disable-web"
- # Parallel implementation
- if ! use mpi; then
- EXTRA_CONF="${EXTRA_CONF} --enable-serial"
- fi
-
- ./configure ${EXTRA_CONF} || die "Configure failed."
- CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" make -e || die "Make failed."
-
-# Install parallel files only on x86, otherwise the install fails with the error:
-# i386 architecture of input file `mp.o' is incompatible with i386:x86-64 output
- if [[ "${ARCH}" == "x86" ]] ; then
- if use mpi; then
- cd src/parallel
- make || die "Parallel make failed."
- fi
- fi
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "Failed to install program files."
- exeinto "/opt/${PN}/bin"
- if [[ "${ARCH}" == "x86" ]] ; then
- if use mpi; then
- doexe "${S}/src/parallel/${PN}_p" || \
- die "Failed to install parallel MEME implementation."
- fi
- fi
- keepdir "/var/log/${PN}"
- fperms 777 "/var/log/${PN}"
-}
-
-pkg_postinst() {
- echo
- einfo 'Prior to using MEME/MAST, you should source "/opt/meme/etc/meme.sh"'
- einfo '(or "/opt/meme/etc/meme.csh" if you use a csh-style shell). To do'
- einfo 'this automatically with bash, add the following statement to your'
- einfo '"~/.bashrc" file (without the quotes): "source /opt/meme/etc/meme.sh".'
- echo
- einfo 'Log files are produced in the "/var/log/meme" directory.'
- echo
-}
-
-src_test() {
- make test || die "Regression tests failed."
-}