summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2008-06-29 06:13:46 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2008-06-29 06:13:46 +0000
commit90fbfc513b5af86faef1af2a3d8c550f45b4b1b7 (patch)
tree3b12eaeb3e1c300d8ea5d4ce8c3b91a1a7821c30 /sci-biology/meme
parentimport for testing (diff)
downloadje_fro-90fbfc513b5af86faef1af2a3d8c550f45b4b1b7.tar.gz
je_fro-90fbfc513b5af86faef1af2a3d8c550f45b4b1b7.tar.bz2
je_fro-90fbfc513b5af86faef1af2a3d8c550f45b4b1b7.zip
add mpi stuff
svn path=/; revision=234
Diffstat (limited to 'sci-biology/meme')
-rw-r--r--sci-biology/meme/Manifest2
-rw-r--r--sci-biology/meme/meme-3.5.7.ebuild37
2 files changed, 21 insertions, 18 deletions
diff --git a/sci-biology/meme/Manifest b/sci-biology/meme/Manifest
index 2a82c34..a4fa3db 100644
--- a/sci-biology/meme/Manifest
+++ b/sci-biology/meme/Manifest
@@ -1,5 +1,5 @@
AUX meme-3.5.7-Makefile.am.patch 377 RMD160 a8d4551bcb53b66044ded24421cd2a17bf93b3ad SHA1 96530d5a58b8c01c99ae2b5463b7448758d7fb3d SHA256 ef3f0d8ccca728325d9f9b4f485e8cd4db2ced50fc975f8b66f3b76fcf17b5e8
DIST meme_3.5.7.tar.gz 1101383 RMD160 ab2c38873d30490933151520b09bec0644d2c492 SHA1 f04f233be63a75a78ea878d025a0476099e496cd SHA256 b5d84d969f69dbe02f2636e2161c53212f7c9a5b141ae2ed759f99a322f221a9
-EBUILD meme-3.5.7.ebuild 2687 RMD160 43e134a5db21694768145a23c6bbbe21a5d76cd9 SHA1 2fd3e83ee2770ceb0120da0c5ee40edd32f7616c SHA256 7ae8871a9845c34855b5754eb90dc5af00a87ec057e87708ba5e339a084641e0
+EBUILD meme-3.5.7.ebuild 2689 RMD160 697a74a2d96123068db025e1c5bf647393e1090b SHA1 87d7c0338489e0eba99aa5b8466290f2eedca946 SHA256 e23be35ddc1b739061dc20ed485da440bf552248d23683d077be5ea966f2ca18
MISC ChangeLog 566 RMD160 74f3916e717ce84e593217bd53c0b99eb10a14c9 SHA1 799df7e3146993c26d897dd8224f302fd0970fcc SHA256 909bde96179b1488d0bcd854d9cd2d3a37a6e55c6c9756623fae0e77e8562dff
MISC metadata.xml 165 RMD160 b247a16b6552b292d1249ff4e8ea5060ad2c4372 SHA1 a9f91a3a303f4c85430e21eca09913e1c9426366 SHA256 560c375768c8e164d954d61924f110da785b4771012cb830963eaa267a319132
diff --git a/sci-biology/meme/meme-3.5.7.ebuild b/sci-biology/meme/meme-3.5.7.ebuild
index a51a6aa..5a20531 100644
--- a/sci-biology/meme/meme-3.5.7.ebuild
+++ b/sci-biology/meme/meme-3.5.7.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $
-
-inherit autotools eutils toolchain-funcs
+WEBAPP_OPTIONAL="yes"
+inherit autotools eutils toolchain-funcs webapp
DESCRIPTION="The MEME/MAST system - Motif discovery and search"
HOMEPAGE="http://meme.sdsc.edu/meme"
SRC_URI="http://meme.nbcr.net/downloads/${PN}_${PV}.tar.gz"
LICENSE="meme"
-
+WEBAPP_MANUAL_SLOT="yes"
SLOT="0"
KEYWORDS="~x86 ~amd64"
# Other possible USE flags include "debug", "client", "server", "web",
# "queue". Other variables must be set at compile time, but only when
# the Web server is built. Right now, Web server and client are disabled.
-IUSE="mpi"
+IUSE="mpi webapp"
DEPEND=">=dev-lang/perl-5.6.1
mpi? ( virtual/mpi )"
@@ -26,38 +26,41 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-Makefile.am.patch"
-# epatch "${FILESDIR}/${P}-patch1.patch"
-# epatch "${FILESDIR}/${P}-patch2.patch"
einfo "Regenerating autotools files..."
eautoreconf
}
src_compile() {
- local EXTRA_CONF
- # Build system is too bugy to make the programs use standard locations.
+
+ # Build system is too buggy to make the programs use standard locations.
# Put everything in "/opt" instead.
+
+ local EXTRA_CONF
EXTRA_CONF="${EXTRA_CONF} --prefix=/opt/${PN}"
EXTRA_CONF="${EXTRA_CONF} --with-logs=/var/log/${PN}"
# Connect hyperlinks to official Web site.
EXTRA_CONF="${EXTRA_CONF} --with-url=http://meme.nbcr.net/meme"
- # Disable Web server, client and Web site.
- EXTRA_CONF="${EXTRA_CONF} --disable-server --disable-client --disable-web"
# Parallel implementation
if ! use mpi; then
EXTRA_CONF="${EXTRA_CONF} --enable-serial"
fi
+ if use webapp; then
+ EXTRA_CONF="${EXTRA_CONF} --enable-server --enable-client --enable-web"
+ fi
+
./configure ${EXTRA_CONF} || die "Configure failed."
- CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" make -e || die "Make failed."
+
+ CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" emake -e || die "Make failed."
# Install parallel files only on x86, otherwise the install fails with the error:
# i386 architecture of input file `mp.o' is incompatible with i386:x86-64 output
- if [[ "${ARCH}" == "x86" ]] ; then
- if use mpi; then
- cd src/parallel
- make || die "Parallel make failed."
- fi
- fi
+# if [[ "${ARCH}" == "x86" ]] ; then
+# if use mpi; then
+ cd src/parallel
+ CC="$(tc-getCC)" ac_cc_opt="${CFLAGS}" emake || die "Parallel make failed."
+# fi
+# fi
}
src_install() {