summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2007-11-26 14:24:49 +0000
committerJory Pratt <anarchy@gentoo.org>2007-11-26 14:24:49 +0000
commit430e21199ff59c6ec5755d3ca20b67ca7b7d7d59 (patch)
tree277716b2fa557c657a43b1f9773d28f891d94dbf /x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
parentfix broken sed when debug useflag is enabled (diff)
downloadje_fro-430e21199ff59c6ec5755d3ca20b67ca7b7d7d59.tar.gz
je_fro-430e21199ff59c6ec5755d3ca20b67ca7b7d7d59.tar.bz2
je_fro-430e21199ff59c6ec5755d3ca20b67ca7b7d7d59.zip
misc fixes
svn path=/; revision=130
Diffstat (limited to 'x11-drivers/ati-drivers/ati-drivers-8.433.ebuild')
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.433.ebuild61
1 files changed, 33 insertions, 28 deletions
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
index 151301f..71e6b75 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
@@ -57,6 +57,10 @@ QA_TEXTRELS_amd64="
S="${WORKDIR}"
pkg_setup() {
+
+ # Define module dir.
+ MODULE_DIR="${S}/common/lib/modules/fglrx/build_mod"
+
#check kernel and sets up KV_OBJ
MODULE_NAMES="fglrx(video:${S}/common/lib/modules/fglrx/build_mod/2.6.x)"
BUILD_TARGETS="kmod_build"
@@ -94,18 +98,6 @@ pkg_setup() {
die "CONFIG_PARAVIRT enabled"
fi
- if linux_chkconfig_present SLUB; then
- ewarn "You have selected support for the SLUB allocator. Suspending is"
- ewarn "known to be broken with this allocator and ati-drivers. If you"
- ewarn "need support for Suspend-To-Ram or Suspend-To-Disk, select SLAB"
- ewarn "instead. To do this enable CONFIG_SLAB and disable CONFIG_SLUB"
- ewarn "in /usr/src/linux/.config or select"
- ewarn " General setup --->"
- ewarn " Choose SLAB allocator (SLUB) --->"
- ewarn " (X) SLAB"
- ewarn "in 'menuconfig'"
- fi
-
# xorg-server 1.1 and its prereleases correspond to xorg 7.1.
if has_version ">=x11-base/xorg-server-1.0.99"; then
BASE_DIR="${S}/x710"
@@ -125,11 +117,10 @@ pkg_setup() {
}
src_unpack() {
- local src="${DISTDIR}/${A}"
-
#Switching to a standard way to extract the files since otherwise no signature file
#would be created
- sh "${src}" --extract "${S}"
+ local src="${DISTDIR}/${A}"
+ sh "${src}" --extract "${S}" 2&>1 /dev/null
# These are the userspace utilities that we also have source for.
# We rebuild these later.
@@ -138,10 +129,11 @@ src_unpack() {
"${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR}/libfglrx_gamma* \
|| die "bin rm failed"
- if use debug; then
- sed -i '/^#define DRM_DEBUG_CODE/s/0/1/' \
- "${S}/common/lib/modules/fglrx/build_mod/firegl_public.c" \
- || die "Failed to enable debug output."
+ if use debug; then
+ # Enable debug mode in the Source Code.
+ sed -i '/^#define DRM_DEBUG_CODE/s/0/1/' \
+ "${MODULE_DIR}/firegl_public.c" \
+ || die "Failed to enable debug output."
fi
if use acpi; then
@@ -152,13 +144,16 @@ src_unpack() {
"${S}/common/etc/ati/authatieventsd.sh" \
|| die "sed failed."
- # Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/
- epatch "${FILESDIR}"/ati-powermode-opt-path.patch
- sed -i -e 's:finger:who:' "${S}/common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh" \
- || die "Replacing 'finger' with 'who' failed."
- fi
+ # Since "who" is in coreutils, we're using that one instead of "finger".
+ sed -i -e 's:finger:who:' \
+ "${S}/common/usr/share/doc/fglrx/examples/etc/acpi/ati-powermode.sh" \
+ || die "Replacing 'finger' with 'who' failed."
+ # Adjust paths in the script from /usr/X11R6/bin/ to /opt/bin/ and
+ # add funktion to detect default state.
+ epatch "${FILESDIR}"/ati-powermode-opt-path-1.patch
+ fi
- pushd common/lib/modules/fglrx/build_mod >/dev/null
+ pushd ${MODULE_DIR} >/dev/null
ln -s "${ARCH_DIR}"/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC$(gcc-major-version) \
|| die "symlinking precompiled core failed"
@@ -174,11 +169,11 @@ src_unpack() {
|| die "MODVERSIONS sed failed"
popd >/dev/null
- # Enable suspend support on smp with 2.6.23
+ # Fix Suspend on 2.6.23 kernel.
if kernel_is ge 2 6 23; then
sed -i 's:CONFIG_SUSPEND_SMP:CONFIG_PM_SLEEP_SMP:' \
- "${S}/common/lib/modules/fglrx/build_mod/firegl_public.h" \
- || die "Fixing suspend for kernel 2.6.23 failed."
+ "${MODULE_DIR}/firegl_public.h" \
+ || die "Fixing suspend for kernel 2.6.23 failed."
fi
mkdir extra || die "mkdir failed"
@@ -434,6 +429,16 @@ pkg_postinst() {
ewarn ' Option "XAANoOffscreenPixmaps" "true"'
ewarn "in the Device Section of /etc/X11/xorg.conf."
+ # Warning per bug #199720
+ elog "***** Warning *****"
+ elog "ATI has stated this is not a complete release version and should"
+ elog "not be distributed. Although it is the version presented on their"
+ elog "website for certain chipsets/cards. Due to this version being"
+ elog "incomplete, some users will experience \"(EE) No devices detected.\""
+ elog "errors. This is known and please mask this version locally if you"
+ elog "experience that. For further information please see the following"
+ elog "http://www2.ati.com/drivers/linux/catalyst_711_linux.html"
+
linux-mod_pkg_postinst
}