summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2007-11-23 03:19:54 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2007-11-23 03:19:54 +0000
commit432d4bf5f143f4f5c2e9eef6053bbf06a8b3b9bd (patch)
tree15e312237f211c659e5749602416d445de952e3d /x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
parentfixup (diff)
downloadje_fro-432d4bf5f143f4f5c2e9eef6053bbf06a8b3b9bd.tar.gz
je_fro-432d4bf5f143f4f5c2e9eef6053bbf06a8b3b9bd.tar.bz2
je_fro-432d4bf5f143f4f5c2e9eef6053bbf06a8b3b9bd.zip
add debug use flag for testing
svn path=/; revision=123
Diffstat (limited to 'x11-drivers/ati-drivers/ati-drivers-8.433.ebuild')
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.433.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
index 8aa314b..9b90e22 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.433.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-IUSE="acpi multilib"
+IUSE="acpi multilib debug"
inherit eutils multilib linux-mod toolchain-funcs versionator
@@ -138,6 +138,12 @@ src_unpack() {
"${ARCH_DIR}"/usr/X11R6/${PKG_LIBDIR}/libfglrx_gamma* \
|| die "bin rm failed"
+ if use debug; then
+ sed -i '/^#define DRM_DEBUG_CODE/s/0/1/' \
+ "${S}/common/lib/modules/fglrx/firegl_public.c" \
+ || die "Failed to enable debug output."
+ fi
+
if use acpi; then
sed -i \
-e "s:/var/lib/xdm/authdir/:/etc/X11/xdm/authdir/:" \