summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2008-01-28 16:36:40 +0000
committerJory Pratt <anarchy@gentoo.org>2008-01-28 16:36:40 +0000
commitedec4458f97811ba696200927c62d360430ef11c (patch)
tree9132477a20ebfde2981632cb9a19d0e81b4ce589 /x11-drivers/ati-drivers/ati-drivers-8.452.ebuild
parentthis one actually compiles (diff)
downloadje_fro-edec4458f97811ba696200927c62d360430ef11c.tar.gz
je_fro-edec4458f97811ba696200927c62d360430ef11c.tar.bz2
je_fro-edec4458f97811ba696200927c62d360430ef11c.zip
fix check for PCI_LEGACY
svn path=/; revision=171
Diffstat (limited to 'x11-drivers/ati-drivers/ati-drivers-8.452.ebuild')
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-8.452.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-drivers/ati-drivers/ati-drivers-8.452.ebuild b/x11-drivers/ati-drivers/ati-drivers-8.452.ebuild
index 45efe27..0ceea1f 100644
--- a/x11-drivers/ati-drivers/ati-drivers-8.452.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-8.452.ebuild
@@ -73,9 +73,9 @@ pkg_setup() {
die "Need a 2.6 kernel to compile against!"
fi
- if kernel_is ge 2 6 24; then
- CONFIG_CHECK="PCI_LEGACY"
- ERROR_PCI_LEGACY="${P} requires support for pci_find_slot (CONFIG_PCI_LEGACY)."
+ if kernel_is ge 2 6 24 && ! linux_chkconfig_present PCI_LEGACY; then
+ eerror "${P} requires support for pci_find_slot."
+ die "${P} requires support for pci_find_slot."
fi
if ! linux_chkconfig_present MTRR; then